Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160713 - Missing/Incorrect BuildRequires
Summary: Missing/Incorrect BuildRequires
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ecj
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 20:20 UTC by Andreas Thienemann
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-21 18:34:27 UTC


Attachments (Terms of Use)

Description Andreas Thienemann 2005-06-16 20:20:43 UTC
During a test rebuild of ecj-3.1-0.M4.9 in the mock builder, the following
problem manifests itself:

+ find -name '*.class' -or -name '*.properties' -or -name '*.rsc'
+ xargs jar cf ../../../ecj-2.1.3.jar
xargs: jar: No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.45084 (%build)

The reason is, that the Required libgcj installs fastjar, but doesn't set up the
correct symlink with the alternatives system.
This is done by the java-$ver-compat package, which is not being installed.

According to nasrat the best way of dealing with this issue is dropping the
BuildRequires for gcc-java and libgcj and just setting a BuildRequire for
java-$ver-compat, or even better the virtual java-devel package which is
provided by the java-compat package. This will fix the alternatives problem and
pull in gcj and libgcj as well.

Comment 1 Thomas Fitzsimmons 2005-10-01 21:29:30 UTC
Gary, have we done this already with the java-gcj-compat virtual provide you
created?


Comment 2 Gary Benson 2005-10-03 09:14:03 UTC
This should have been fixed in eclipse one way or another.

Comment 3 Thomas Fitzsimmons 2005-10-03 14:42:41 UTC
Andrew, can you confirm/deny/close this bug?


Comment 4 Andrew Overholt 2005-10-03 14:46:08 UTC
We currently have this in eclipse.spec:

BuildRequires:  java-gcj-compat-devel >= 1.0.33

Gary, is that correct?

Comment 5 Gary Benson 2005-10-03 14:57:32 UTC
That would do it, but you probably should have:

BuildRequires: java

as well, just in case you ever delete the gcj-specific stuff.

Comment 6 Andrew Overholt 2005-10-03 14:58:39 UTC
Yeah, I have that in the non-gcj_support %if block.

I don't know what to do now.  Shall we close this?

Comment 7 Gary Benson 2005-10-03 15:35:40 UTC
Make the "BuildRequires: java" unconditional and then close the bug?

Comment 8 Andrew Overholt 2005-10-21 18:34:27 UTC
I actually like things the way they are right now.  If anyone feels strongly
about changing it, go ahead and do it.  Closing RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.