Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1607118 - [IPv6] - Engine does not report out-of-sync on ipv6-enabled network
Summary: [IPv6] - Engine does not report out-of-sync on ipv6-enabled network
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.2.2
Hardware: Unspecified
OS: Unspecified
medium
low vote
Target Milestone: ovirt-4.3.1
: ---
Assignee: eraviv
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On: 1467332
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-22 07:59 UTC by eraviv
Modified: 2019-03-01 10:17 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.3.1.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-01 10:17:47 UTC
oVirt Team: Network
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 95800 master MERGED core: report out-of-sync for ipv6 2019-02-13 19:41:11 UTC
oVirt gerrit 96792 master MERGED core: equate ipv6 gateway "::" with "no gateway" 2019-02-13 19:41:13 UTC
oVirt gerrit 97602 master MERGED core: add query whether default route network is attached to host 2019-02-16 17:11:05 UTC
oVirt gerrit 97693 master MERGED webadmin: alert default route network missing on host 2019-02-16 17:11:07 UTC

Description eraviv 2018-07-22 07:59:36 UTC
Description of problem:
Engine does not report out-of-sync on ipv6-enabled network.

Version-Release number of selected component (if applicable):
ovirt-engine 4.3-master

How reproducible:
100%

Steps to Reproduce:
1. create network with ipv6 config on host
2. change the ipv6 boot protocol on the host bridge
3. refresh host capabilities from engine

Actual results:
the network remains in sync

Expected results:
the network should be out of sync

Additional info:
see NetworkInSyncWithVdsNetworkInterface.java#L76-82:
this functionality exists but was disabled due to ipv6 related bugs in vdsm\engine.

Comment 1 Sandro Bonazzola 2019-01-28 09:34:03 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 2 eraviv 2019-02-24 07:32:02 UTC
Dear QE,

Please make sure to test all permutations of configurations on host interfaces:
- ipv4 only
- ipv6 static configuration only
- ipv4 + ipv6 static


Thanks

Comment 3 Michael Burman 2019-02-24 07:57:23 UTC
(In reply to eraviv from comment #2)
> Dear QE,
> 
> Please make sure to test all permutations of configurations on host
> interfaces:
> - ipv4 only
> - ipv6 static configuration only
> - ipv4 + ipv6 static
> 
> 
> Thanks

Eitan, i don't follow. IPv4? what i need to test here? you touched only ipv6 i hope. Why i need to check ipv4 out-of-sync? 
We don't support dual stack, what you want to test with ipv4 + ipv6 static? 
This wasn't part of the changes planned.

Comment 4 eraviv 2019-02-24 08:31:27 UTC
correction:
-ipv4 only - check there are no regressions
- dual stack - my mistake

Comment 5 Michael Burman 2019-02-26 12:26:51 UTC
(In reply to eraviv from comment #4)
> correction:
> -ipv4 only - check there are no regressions
> - dual stack - my mistake

ACK

Verified on - rhvm-4.3.1.1-0.1.el7.noarch

Comment 6 Sandro Bonazzola 2019-03-01 10:17:47 UTC
This bugzilla is included in oVirt 4.3.1 release, published on February 28th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.