Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1607054 - pandoc fails to install on rawhide due nothing providing libHSth-abstraction
Summary: pandoc fails to install on rawhide due nothing providing libHSth-abstraction
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pandoc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1604083
Blocks: 1598195 1601163 1603251 1603530 1606870
TreeView+ depends on / blocked
 
Reported: 2018-07-21 11:59 UTC by Tadej Janež
Modified: 2018-07-25 08:23 UTC (History)
6 users (show)

Fixed In Version: binutils-2.31.1-3.fc29, pandoc-2.0.6-6.fc29
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-24 18:45:02 UTC


Attachments (Terms of Use)

Description Tadej Janež 2018-07-21 11:59:23 UTC
Description of problem:
The current version of pandoc in rawhide fails to install with the following error (e.g., on x86_64):

Error: 
   Problem: conflicting requests
    - nothing provides libHSth-abstraction-0.2.6.0-KdJUlqAwMfUIgxZVMgLLVd-ghc8.2.2.so()(64bit) needed by pandoc-2.0.6-5.fc29.x86_64

Version-Release number of selected component (if applicable):
pandoc-2.0.6-5.fc29

How reproducible:
Always

Additional info:
I encountered this when trying to build bup, which has a BuildRequires on pandoc, in Rawhide today:
https://koji.fedoraproject.org/koji/taskinfo?taskID=28491999

Comment 1 Miro Hrončok 2018-07-23 10:06:47 UTC
I've got:

  - nothing provides libHSth-abstraction-0.2.6.0-KdJUlqAwMfUIgxZVMgLLVd-ghc8.2.2.so()(64bit) needed by pandoc-citeproc-0.12.2.5-4.fc29.x86_64


Also, when I try to bump build pandoc-citeproc:

Error: 
 Problem 1: conflicting requests
  - nothing provides ghc-devel(th-abstraction-0.2.6.0-KdJUlqAwMfUIgxZVMgLLVd) needed by ghc-aeson-devel-1.2.3.0-3.fc29.x86_64
 Problem 2: conflicting requests
  - nothing provides libHSth-abstraction-0.2.6.0-KdJUlqAwMfUIgxZVMgLLVd-ghc8.2.2.so()(64bit) needed by ghc-aeson-pretty-devel-0.8.5-3.fc29.x86_64
 Problem 3: conflicting requests
  - nothing provides ghc-devel(http-client-0.5.7.1-4kyJ4nMDdL3BONGiqBslly) needed by ghc-pandoc-devel-2.0.6-5.fc29.x86_64
 Problem 4: conflicting requests
  - nothing provides libHSth-abstraction-0.2.6.0-KdJUlqAwMfUIgxZVMgLLVd-ghc8.2.2.so()(64bit) needed by ghc-yaml-devel-0.8.25.1-3.fc29.x86_64
 Problem 5: package ghc-pandoc-types-devel-1.17.3-3.fc29.x86_64 requires ghc-pandoc-types(x86-64) = 1.17.3-3.fc29, but none of the providers can be installed
  - conflicting requests
  - nothing provides libHSth-abstraction-0.2.6.0-KdJUlqAwMfUIgxZVMgLLVd-ghc8.2.2.so()(64bit) needed by ghc-pandoc-types-1.17.3-3.fc29.x86_64

This seems to be rather large scaled :(

Comment 2 Miro Hrončok 2018-07-23 11:14:36 UTC
This seems to need just a chain rebuild of all the deps. Resolving and trying in mock.

Comment 3 Miro Hrončok 2018-07-23 11:37:30 UTC
Got it will rebuild (in this order):

ghc-aeson
ghc-aeson-pretty
ghc-doctemplates
ghc-http-client
ghc-asn1-types
ghc-tasty-quickcheck
ghc-asn1-encoding
ghc-cryptonite
ghc-pem
ghc-asn1-parse
ghc-x509
ghc-x509-store
ghc-x509-validation
ghc-tls
ghc-x509-system
ghc-connection
ghc-http-client-tls
ghc-yaml
ghc-pandoc-types
ghc-texmath
ghc-skylighting
ghc-doctemplates
pandoc
pandoc-citeproc

Comment 5 Miro Hrončok 2018-07-23 12:48:32 UTC
ghc-aeson-pretty failed in Koji, yet it works in my mock :(

Comment 6 Miro Hrončok 2018-07-23 14:07:03 UTC
So does ghc-asn1-encoding, same error:


https://koji.fedoraproject.org/koji/taskinfo?taskID=28541879

Linking dist/build/tests-asn1-encoding/tests-asn1-encoding ...
/tmp/ghc8eea_0/ghc_2.o(.gnu.build.attributes..text.startup+0x18): error: relocation refers to local symbol "" [11], which is defined in a discarded section
  section group signature: "(null)"
/tmp/ghc8eea_0/ghc_2.o(.gnu.build.attributes..text.startup+0x20): error: relocation refers to local symbol "" [2], which is defined in a discarded section
  section group signature: "(null)"
collect2: error: ld returned 1 exit status
`gcc' failed in phase `Linker'. (Exit code: 1)

Comment 7 Miro Hrončok 2018-07-23 15:40:15 UTC
Switching back to new, as this won't be that easy.

Comment 8 Miro Hrončok 2018-07-23 16:56:05 UTC
ghc-aeson-pretty
ghc-asn1-encoding
ghc-yaml
ghc-doctemplates
ghc-texmath

all failed with the same error.

architectures with skipped tests succeeded. if no proper fix is found, a quick rebuild with tests skipped might fix this.

Comment 9 Miro Hrončok 2018-07-23 17:41:52 UTC
%undefine _annotated_build also seems to solve this.

Comment 10 Adam Williamson 2018-07-24 03:42:27 UTC
I'm running builds with `%undefine _annotated_build` now. We can always rebuild without that workaround if whatever ld or annobin bug is causing the build failures gets fixed, but for now, it'd be nice to have the broken deps fixed.

Comment 11 Jens Petersen 2018-07-24 05:35:58 UTC
Thanks for working on this, guys: in the meantime I have been working on a bigger Haskell packages update for F29.

Comment 12 Jens Petersen 2018-07-24 05:37:02 UTC
(In reply to Adam Williamson from comment #10)
> I'm running builds with `%undefine _annotated_build` now. We can always
> rebuild without that workaround if whatever ld or annobin bug is causing the
> build failures gets fixed, but for now, it'd be nice to have the broken deps
> fixed.

Has it been reported?

Comment 13 Adam Williamson 2018-07-24 06:10:21 UTC
Not sure if there's a specific bug for the remaining issue, no. Miro might have filed one?

Comment 14 Miro Hrončok 2018-07-24 07:56:57 UTC
Not in bugzilla, but in devel ML. Nick Clifton 
 was later CCed in the thread. 

https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/KH4QQBW5PJBL6HMOOAJWHTF5W2MMPUAX/

Comment 15 Nick Clifton 2018-07-24 09:43:44 UTC
Hi Guys,

  This problem should be fixed in  binutils-2.31.1-3.fc29

Cheers
  Nick

Comment 16 Miro Hrončok 2018-07-24 10:54:36 UTC
Indeed, ghc-aeson-pretty now builds fine without "%undefine _annotated_build".

Should we revert the commits and leave it be, or bump the release and do another rebuild? I'm not sure how important it is to have the builds annotated.

Comment 17 Zbigniew Jędrzejewski-Szmek 2018-07-24 11:11:28 UTC
Removing it would be nice, since otherwise it's likely that the temporary workaround will persist forever.

Comment 18 Miro Hrončok 2018-07-24 11:51:21 UTC
We'll remove it for sure, yet I don't know whether we should just revert the commit or bump release and rebuild again as well.

Comment 19 Adam Williamson 2018-07-24 15:41:59 UTC
Don't see any harm in rebuilding them. I added it to I think four or five packages, I'll rebuild those today if no-one else gets to it.

Comment 20 Adam Williamson 2018-07-24 19:02:38 UTC
For the record, Miro re-enabled annotated build and rebuilt all the packages we had temporarily disabled it on - so everything here should be addressed now. Thanks Miro!

Comment 21 Jens Petersen 2018-07-25 02:58:50 UTC
Thanks a lot Miro and Adam, this really helped me a lot!
Since I am a bit swamped at the moment.

Comment 22 Adam Williamson 2018-07-25 05:34:58 UTC
It's all self-interest really, I need pandoc working or else I can't cut releases of any of my projects :P

Comment 23 Jens Petersen 2018-07-25 06:21:55 UTC
👍

Comment 24 Miro Hrončok 2018-07-25 08:23:01 UTC
(In reply to Adam Williamson from comment #22)
> It's all self-interest really, I need pandoc working or else I can't cut
> releases of any of my projects :P

Same for me, I was just blocked by this :)


Note You need to log in before you can comment on or make changes to this bug.