Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160703 - Files are not saved when extracting archive
Summary: Files are not saved when extracting archive
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
: 160887 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 19:24 UTC by Nicholas Stiffler
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-27 06:24:31 UTC


Attachments (Terms of Use)

Description Nicholas Stiffler 2005-06-16 19:24:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I recently upgraded from FC3 to FC4.  Prior to the upgrade, I utilized file-roller often and never had any issues.  When I open an archive (only tested on tar.gz files) and extract it, the program behaves exactly as I would expect.  But, when I look in the folder where it was extracted to, it isn't there.  I have plenty of available harddisk space.  I also tried manually extracting them from the command line and this worked fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open archive by clicking on icon in Nautilus or automatically opening from download in Firefox.
2. Click "Extract files from the archive" button.
3. Click Exctract button.
  

Actual Results:  Program behaved fine, but files weren't saved to disk.

Expected Results:  Files should be where I tried to extract them.

Additional info:

Comment 1 Nicholas Stiffler 2005-06-16 22:35:03 UTC
Apparently, when selecting the folder to extract to, it was being extracted to
the folder that was highlited, rather than the one that was opened, as I was
accustom to.  The files had been extracted all along, but in the top folder in
my diectory listing.  Is this a new feature of gnome or possiblely a setting
that was changed when I upgraded?

Comment 2 Marc Deslauriers 2005-07-23 01:16:59 UTC
This is actually a gtk2 filechooser bug that was fixed in 2.6.8. Patch is
available in cvs here:

http://cvs.gnome.org/viewcvs/gtk%2B/gtk/gtkfilechooserdefault.c?r1=1.240.2.15&r2=1.240.2.16

Could we get gtk updated to 2.6.8, or 2.6.7 with the patch applied? File-roller
and some other apps act pretty weird without it.

Comment 3 Marc Deslauriers 2005-07-23 01:18:15 UTC
*** Bug 160887 has been marked as a duplicate of this bug. ***

Comment 4 David Zeuthen 2005-07-23 16:01:27 UTC
Reassigning to gtk2 maintainer

Comment 5 Matthias Clasen 2006-11-27 06:24:31 UTC
Thank you for the bug report. However, Fedora Project no longer maintains this
version of the product. Please upgrade to the latest version and open a new bug
if the problem persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older
releases, and if you believe this bug is interesting to them, please report the
problem against Fedora Legacy component




Note You need to log in before you can comment on or make changes to this bug.