Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160700 - hidups causes system slowdown and lots of errors
Summary: hidups causes system slowdown and lots of errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nut
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Brian Brock
URL:
Whiteboard:
: 164051 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 19:03 UTC by Gregory Gulik
Modified: 2007-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-04 09:59:58 UTC


Attachments (Terms of Use)

Description Gregory Gulik 2005-06-16 19:03:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
I recently upgraded a system from FC3 to FC4 and immediately noticed that after the upgrade the system felt significantly slower.  It was so slow the system couldn't keep up with my typing in most applications.  This is an Athlon XP 2500+ system.

After a lot of experimentation I finally realized the problem was the hidups driver with an APC Back-UPS RS.  As soon as I stopped the ups service the system performance returned to normal!  I never had any suck problems with FC3 or even FC2 previous to that.

Additionally the following appears in /var/log/messages when hidups is started:
Jun 16 14:00:29 penguin hidups[4499]: Startup successful
Jun 16 14:00:29 penguin upsd[4500]: Connected to UPS [office]: hidups-hiddev0
Jun 16 14:00:29 penguin hidups[4499]: Ignoring x86 page event 0xff860060 (8)
Jun 16 14:00:29 penguin hidups[4499]: Ignoring x86 page event 0xff860060 (8)
Jun 16 14:00:29 penguin upsd[4501]: Startup successful
Jun 16 14:00:29 penguin hidups[4499]: Ignoring x86 page event 0xff860060 (8)
Jun 16 14:00:33 penguin last message repeated 2 times
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x8500d1 (1)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x850043 (0)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x840073 (0)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x85004b (0)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x840065 (0)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x8500db (0)


Version-Release number of selected component (if applicable):
nut-2.0.1-1

How reproducible:
Always

Steps to Reproduce:
1. Plug in UPS via USB
2. service ups start
3.
  

Actual Results:  VERY poor performance.  My Athlon XP 2500+ is barely useable.

Jun 16 14:00:29 penguin hidups[4499]: Startup successful
Jun 16 14:00:29 penguin upsd[4500]: Connected to UPS [office]: hidups-hiddev0
Jun 16 14:00:29 penguin hidups[4499]: Ignoring x86 page event 0xff860060 (8)
Jun 16 14:00:29 penguin hidups[4499]: Ignoring x86 page event 0xff860060 (8)
Jun 16 14:00:29 penguin upsd[4501]: Startup successful
Jun 16 14:00:29 penguin hidups[4499]: Ignoring x86 page event 0xff860060 (8)
Jun 16 14:00:33 penguin last message repeated 2 times
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x8500d1 (1)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x850043 (0)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x840073 (0)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x85004b (0)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x840065 (0)
Jun 16 14:00:33 penguin hidups[4499]: Unhandled event: 0x8500db (0)


Expected Results:  The ups software should run in the background with no impact on system performance and no errors logged to /var/log/messages

Additional info:

Comment 1 Gregory Gulik 2005-06-16 20:32:32 UTC
For testing purposes I obtained the hidups executable from Fedora Core 3 and the
same thing happened.  That might indicate a problem with the USB or HID drivers
rather than the hidups program.

Comment 2 Ngo Than 2005-07-20 15:17:17 UTC
could you please try the new nut-2.0.2-1 from rawhide, it will be available
in rawhide in next day. For testing you should probably boot the kernel from FC3,
which worked before. Thanks

Comment 3 Gregory Gulik 2005-07-20 15:32:56 UTC
I am already running nut-2.0.2-1 but I am unable to boot an FC3 kernel as I no
longer have any systems with FC3 installed any more.

I am still getting tons of errors in dmesg but I'm no longer experiencing the
dramatic slowdown I was getting when I first installed FC4.

Comment 4 Ngo Than 2005-07-20 15:43:07 UTC
yes, it seems a bug in USB or HID drivers. You could install the working kernel
from FC3 on your FC4. Could you please try this? Thanks

Comment 5 Gregory Gulik 2005-07-20 15:58:20 UTC
I installed and rebooted into 2.6.12-1.1372_FC3

I started upsd using nut-2.0.1-1

It seems to be working with no slowdowns but /var/log/messages contains a lot of
the following:

Jul 20 10:58:02 penguin hidups[3625]: Unhandled event: 0x840065 (0)
Jul 20 10:58:02 penguin hidups[3625]: Unhandled event: 0x8500db (0)
Jul 20 10:58:03 penguin hidups[3703]: Ignoring x86 page event 0xff860060 (8)
Jul 20 10:58:03 penguin hidups[3703]: Unhandled event: 0x8500d1 (1)
Jul 20 10:58:03 penguin hidups[3703]: Unhandled event: 0x850043 (0)
Jul 20 10:58:03 penguin hidups[3703]: Unhandled event: 0x840073 (0)
Jul 20 10:58:03 penguin hidups[3703]: Unhandled event: 0x85004b (0)
Jul 20 10:58:03 penguin hidups[3703]: Unhandled event: 0x840065 (0)
Jul 20 10:58:03 penguin hidups[3703]: Unhandled event: 0x8500db (0)
Jul 20 10:58:06 penguin hidups[3625]: Ignoring x86 page event 0xff860060 (8)


Comment 6 Ngo Than 2005-07-20 16:24:28 UTC
reassign it to kernel

Comment 7 Dave Jones 2005-07-28 06:46:07 UTC
Pete, any ideas ? I'm way out of my depth with usb bits..


Comment 8 Pete Zaitcev 2005-09-08 05:11:51 UTC
I'm not versed in details of hiddev either. Takes a lot of reading,
it's a convoluted thing. I suppose I could diff something, then attempt
to match the printed events against any new code. At least Greg told
us to base on 2.6.12-1.1372_FC3, so that's something.

Than is not off the hook completely though. These messages are
printed by the userland and the act of printing eats cycles too.


Comment 9 Dave Jones 2005-09-30 07:12:11 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.


Comment 10 Matthew Saltzman 2005-09-30 13:31:38 UTC
I still see this behavior in kernel-2.6.13-1.1526_FC4.

Comment 11 Gregory Gulik 2005-10-02 23:36:34 UTC
I'm now running Linux penguin 2.6.13-1.1526_FC4 #1 Wed Sep 28 19:15:10 EDT 2005
i686 athlon i386 GNU/Linux

No change from the previous 2.6.12 based kernel in that the errors are still
present but there has been no noticeable system slowdown when using this USB UPS.


Oct  2 18:34:46 penguin hidups[3294]: Unhandled event: 0x840065 (0)
Oct  2 18:34:46 penguin hidups[3294]: Unhandled event: 0x8500db (0)
Oct  2 18:34:47 penguin hidups[2294]: Ignoring x86 page event 0xff860060 (8)
Oct  2 18:34:47 penguin hidups[2294]: Unhandled event: 0x8500d1 (1)
Oct  2 18:34:47 penguin hidups[2294]: Unhandled event: 0x850043 (0)
Oct  2 18:34:47 penguin hidups[2294]: Unhandled event: 0x840073 (0)
Oct  2 18:34:47 penguin hidups[2294]: Unhandled event: 0x85004b (0)
Oct  2 18:34:47 penguin hidups[2294]: Unhandled event: 0x840065 (0)
Oct  2 18:34:47 penguin hidups[2294]: Unhandled event: 0x8500db (0)


Comment 12 Dave Jones 2005-10-02 23:45:54 UTC
these are debug messages from nut.
I suggest to just comment them out for now in an errata.


Comment 13 Ngo Than 2005-10-04 09:59:58 UTC
it's fixed in 2.0.2-0.fc4.1, which will be pushed out this week. 

Comment 14 Dave Jones 2005-11-05 06:29:49 UTC
*** Bug 164051 has been marked as a duplicate of this bug. ***

Comment 15 Gregory Gulik 2005-11-05 17:36:51 UTC
I'm running nut-2.0.2-0.fc4.2 and the problem seems to be fully resolved for me
at least.


Note You need to log in before you can comment on or make changes to this bug.