Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160690 - I'm not able to change MAC address
Summary: I'm not able to change MAC address
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 160684 160685 160686 160688 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 17:32 UTC by Dawid Gajownik
Modified: 2014-03-17 02:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-17 07:34:11 UTC


Attachments (Terms of Use)
ifcfg-eth0 file (deleted)
2005-06-17 06:40 UTC, Dawid Gajownik
no flags Details

Description Bill Nottingham 2005-06-16 19:19:00 UTC
*** Bug 160684 has been marked as a duplicate of this bug. ***

Comment 1 Bill Nottingham 2005-06-16 19:19:06 UTC
*** Bug 160685 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2005-06-16 19:19:22 UTC
*** Bug 160686 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2005-06-16 19:19:24 UTC
*** Bug 160688 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2005-06-16 19:20:14 UTC
Closing, no info in bug report.

Comment 5 Dawid Gajownik 2005-06-16 20:51:50 UTC
I'm really sorry for that spam :( When I was trying to send bugzilla report, I
always got page with bugzilla internal error 500 or something like this (I can
make a screenshot if you like).

Here's the proper bug report:
I'm not able to change MAC address

initscripts-8.11.1-1

I'm not able to change MAC addres of my ethernet card via
/etc/sysconfig/network-scripts/ifcfg-eth0 file.

I've changed:

MACADDR=00:40:F4:31:84:93

to

HWADDR=00:40:F4:31:84:94

and then typed:

[root@X audit]# LANG=C ifdown eth0
UrzÄdzenie eth0 posiada adres MAC inny niż spodziewany, ignorujÄ.
[root@X audit]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:40:F4:31:84:93
          inet addr:192.168.0.7  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8597 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6930 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:8219521 (7.8 MiB)  TX bytes:764360 (746.4 KiB)
          Interrupt:11 Base address:0xd000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1329 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1329 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:39290 (38.3 KiB)  TX bytes:39290 (38.3 KiB)

[root@X audit]#

which means "Device eth0 has different MAC address than expected, ignoring."

BTW I don't know why, but LANG=C does not work. It still shows messages using
system locale.

As you can see, eth0 is up :/ I also tried to modifying ifcfg-eth0 after "ifdown
eth0". "ifup eth0" works, but network card still have the same MAC addres.

Above steps worked without a glitch in FC3.

Comment 6 Bill Nottingham 2005-06-16 20:58:47 UTC
Please attach your ifcfg file.

Comment 7 Dawid Gajownik 2005-06-17 06:40:33 UTC
Created attachment 115594 [details]
ifcfg-eth0 file

Comment 8 Dawid Gajownik 2005-06-17 07:34:11 UTC
Oh, don't bother. In previous Fedora's versions there was always HWADDR entry
and I had to change it to MACADDR.In FC4 there is MACADDR by default. I didn't
remember which one is correct, so I replaced it with HWADDR.

I'm really sorry that I waste your precious time.


Note You need to log in before you can comment on or make changes to this bug.