Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160673 - "sleeping function called from invalid context" error at boot
Summary: "sleeping function called from invalid context" error at boot
Keywords:
Status: CLOSED DUPLICATE of bug 157642
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 15:11 UTC by Joe Orton
Modified: 2015-01-04 22:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-18 09:22:52 UTC


Attachments (Terms of Use)

Description Joe Orton 2005-06-16 15:11:44 UTC
2.6.11-1.1369_FC4smp

Jun 16 10:08:19 radish kernel: scsi0 : sym-2.2.0
Jun 16 10:08:19 radish kernel: input: ImPS/2 Generic Wheel Mouse on isa0060/serio1
Jun 16 10:08:19 radish kernel:   Vendor: FUJITSU   Model: MAJ3182MP         Rev:
0114
Jun 16 10:08:19 radish kernel:   Type:   Direct-Access                      ANSI
SCSI revision: 04
Jun 16 10:08:19 radish kernel:  target0:0:0: tagged command queuing enabled,
command queue depth 16.
Jun 16 10:08:19 radish kernel:  target0:0:0: Beginning Domain Validation
Jun 16 10:08:19 radish kernel: Debug: sleeping function called from invalid
context at mm/slab.c:2126
Jun 16 10:08:19 radish kernel: in_atomic():0, irqs_disabled():1
Jun 16 10:08:19 radish kernel:  [<c014cc1c>] __kmalloc+0x89/0x8b
Jun 16 10:08:19 radish kernel:  [<c014cd41>] kcalloc+0x16/0x4d
Jun 16 10:08:19 radish kernel:  [<e0887f31>] sym_alloc_lcb_tags+0x6a/0x106
[sym53c8xx]
Jun 16 10:08:19 radish kernel:  [<e08879b6>] sym_get_ccb+0x272/0x282 [sym53c8xx]
Jun 16 10:08:19 radish kernel:  [<c01491cc>] __alloc_pages+0xcd/0x401
Jun 16 10:08:19 radish kernel:  [<e085c1b7>] scsi_get_command+0xb2/0xc5 [scsi_mod]
Jun 16 10:08:19 radish kernel:  [<e087fbbb>] sym_queue_command+0x89/0xd3 [sym53c8xx]
Jun 16 10:08:19 radish kernel:  [<e087ff60>] sym53c8xx_queue_command+0x64/0x6c
[sym53c8xx]
Jun 16 10:08:19 radish kernel:  [<e085c782>] scsi_dispatch_cmd+0x170/0x31a
[scsi_mod]
Jun 16 10:08:19 radish kernel:  [<c0240f63>] elv_next_request+0x4f/0x14d
Jun 16 10:08:19 radish kernel:  [<e08624e1>] scsi_request_fn+0x1d5/0x3ba [scsi_mod]
Jun 16 10:08:19 radish kernel:  [<c02439fb>] blk_insert_request+0x8f/0xbb
Jun 16 10:08:19 radish kernel:  [<e086122b>] scsi_insert_special_req+0x2b/0x32
[scsi_mod]
Jun 16 10:08:19 radish kernel:  [<e086146b>] scsi_wait_req+0x82/0xb3 [scsi_mod]
Jun 16 10:08:20 radish kernel:  [<e086136a>] scsi_wait_done+0x0/0x66 [scsi_mod]
Jun 16 10:08:20 radish kernel:  [<e08380cb>] spi_wait_req+0x3b/0x64
[scsi_transport_spi]
Jun 16 10:08:20 radish kernel:  [<e083925e>]
spi_dv_device_compare_inquiry+0xb9/0x102 [scsi_transport_spi]
Jun 16 10:08:20 radish kernel:  [<e083950a>] spi_dv_device_internal+0x6a/0x27e
[scsi_transport_spi]
Jun 16 10:08:20 radish kernel:  [<e08397fd>] spi_dv_device+0xdf/0x14a
[scsi_transport_spi]
Jun 16 10:08:20 radish kernel:  [<e0880610>] sym53c8xx_slave_configure+0xb3/0xf0
[sym53c8xx]
Jun 16 10:08:20 radish kernel:  [<e0863996>] scsi_add_lun+0x19e/0x32a [scsi_mod]
Jun 16 10:08:20 radish kernel:  [<e0863c8a>] scsi_probe_and_add_lun+0x168/0x230
[scsi_mod]
Jun 16 10:08:20 radish kernel:  [<e0864461>] scsi_scan_target+0xc3/0x13b [scsi_mod]
Jun 16 10:08:20 radish kernel:  [<e0864559>] scsi_scan_channel+0x80/0x95 [scsi_mod]
Jun 16 10:08:20 radish kernel:  [<e0864614>] scsi_scan_host_selected+0xa6/0x11e
[scsi_mod]
Jun 16 10:08:20 radish kernel:  [<e085d4ec>] scsi_add_host+0x185/0x1a7 [scsi_mod]
Jun 16 10:08:20 radish kernel:  [<e08646ad>] scsi_scan_host+0x21/0x25 [scsi_mod]
Jun 16 10:08:20 radish kernel:  [<e0881936>] sym2_probe+0xe0/0xfd [sym53c8xx]
Jun 16 10:08:20 radish kernel:  [<c01ddd85>] pci_device_probe_static+0x25/0x31
Jun 16 10:08:20 radish kernel:  [<c01dddb1>] __pci_device_probe+0x20/0x30
Jun 16 10:08:20 radish kernel:  [<c01ddddc>] pci_device_probe+0x1b/0x32
Jun 16 10:08:20 radish kernel:  [<c023c7a8>] driver_probe_device+0x21/0x55
Jun 16 10:08:20 radish kernel:  [<c023c8c6>] driver_attach+0x4f/0x85
Jun 16 10:08:20 radish kernel:  [<c01d2aa8>] kobject_register+0x2e/0x59
Jun 16 10:08:20 radish kernel:  [<c023ccd6>] bus_add_driver+0x88/0xb6
Jun 16 10:08:20 radish kernel:  [<c01ddf87>] pci_register_driver+0x73/0x88
Jun 16 10:08:20 radish kernel:  [<e0812028>] sym2_init+0x28/0x40 [sym53c8xx]
Jun 16 10:08:20 radish kernel:  [<c013b861>] sys_init_module+0xc9/0x20a
Jun 16 10:08:20 radish kernel:  [<c0104025>] syscall_call+0x7/0xb
Jun 16 10:08:20 radish kernel:  target0:0:0: asynchronous.
Jun 16 10:08:20 radish kernel: WIDTH IS 1

Comment 1 Joe Orton 2005-07-05 10:08:48 UTC
Same (well, it looks much the same) in 2.6.12-1.1387_FC4smp.

Comment 2 Dave Jones 2005-07-15 21:51:13 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 3 Dan Carpenter 2005-07-18 08:47:50 UTC
This bug is probably the same thing as bug 157642


Comment 4 Joe Orton 2005-07-18 09:22:52 UTC
Agreed, thanks Dan.

*** This bug has been marked as a duplicate of 157642 ***


Note You need to log in before you can comment on or make changes to this bug.