Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160669 - svn commit fails with: bdb: Program version 4.3 doesn't match environment version
Summary: svn commit fails with: bdb: Program version 4.3 doesn't match environment ver...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: subversion
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 14:46 UTC by Filip Miletic
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-20 10:29:17 UTC


Attachments (Terms of Use)

Description Filip Miletic 2005-06-16 14:46:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; sr-YU; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I recently upgraded from FC3 to FC4.

Now I cannot access the svn repository as the following error is produced

svn failed: bdb: Program version 4.3 doesn't match environment version

I use the Berkeley DB svn repository.

Version-Release number of selected component (if applicable):
subversion-1.1.4-3, db4-4.3.27-3

How reproducible:
Always

Steps to Reproduce:
1. Make a SVN repository on FC3
2. Commit to it on FC3
3. Upgrade to FC4 and retry.
  

Actual Results:  Commit failed, as stated in the Description

Expected Results:  svn should open the database and use it without problems.

Additional info:

Comment 1 Filip Miletic 2005-06-16 15:56:45 UTC
For the record: the issue is solved as follows. Please double check:

1. go to the SVNROOT and enter the dir db:
2. use the 'file' utility to locate all files of type Berkeley DB and run
db42_upgrade on each
3. Move the files with names: __db.001 etc somewhere safe.
4. Retry the svn action that failed before. It should work now.

Comment 2 Filip Miletic 2005-06-16 16:05:21 UTC
See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=159042 for a possibly
related issue, via dependence on db4.

Comment 3 Joerg Martin Liebner 2005-06-19 19:08:20 UTC
I understand, that it might be difficult to provide a general solution for
automatically updating all user repositories at system update. But there should
be at least some kind of support or information provided for the users, such as
a notice in the release notes. I think it is unacceptable to leave the users
alone with unusable repositories, without telling them how to fix this.

Comment 4 Joe Orton 2005-06-20 10:29:17 UTC
Not simply difficult but really impossible.  It should have been in the release
notes, yes, sorry about that.

You should just run "svnadmin recover" on each repository which needs to be
migrated.   It displays an error but fixes the repository for subsequent use.  
(Remember to "chown -R apache" the repos afterwards if using mod_dav_svn)


Comment 5 Filip Miletic 2005-06-20 11:30:03 UTC
(In reply to comment #4)
> Not simply difficult but really impossible.

I would have to agree. There is no way that the installation script could know
that a particular directory is a svn repository.

But the changing the release notes is a good solution too.

Please be so kind to mention this issue in the release notes.

f

Comment 6 Joe Orton 2005-06-20 11:33:18 UTC
It's too late to update the FC4 release notes now, unfortunately.  I'll try to
remember to do so for future releases which this affects.  Sorry for the
inconvenience.


Comment 7 Filip Miletic 2005-06-20 11:36:21 UTC
In that case, why not reopen this issue as a reminder? (just a suggestion, no
reply needed)

f



Note You need to log in before you can comment on or make changes to this bug.