Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160666 - Serial Mouse not working
Summary: Serial Mouse not working
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-mouse
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL: Serial Mouse not working
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 14:27 UTC by Samvinesh Christopher
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-14 22:29:45 UTC


Attachments (Terms of Use)
Output of cat /proc/bus/input/devices before modprobe sermouse; inputattach -bare /dev/ttyS0 --daemon (deleted)
2005-07-01 02:38 UTC, Agustin Barto
no flags Details
Output of cat /proc/bus/input/devices after modprobe sermouse; inputattach -bare /dev/ttyS0 --daemon (deleted)
2005-07-01 02:38 UTC, Agustin Barto
no flags Details

Description Samvinesh Christopher 2005-06-16 14:27:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)

Description of problem:
New Fedore Core 4 Installed. Serial Mouse not working.
PS/2 mouse works fine.


In the same machine, with FC3, it works fine.

Version-Release number of selected component (if applicable):
FC4

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 with PS/2 Mouse
2. Shudown, replace PS/2 mouse with serial mouse
3.
  

Actual Results:  serial mouse does not work.

Expected Results:  serial mouse should have worked

Additional info:

When the kernel boots ttyS0 and ttyS1 messages are displayed twice 
by the serial driver.

Comment 1 Elliot Lee 2005-06-27 20:20:04 UTC
Based on a quick examination of kudzu and system-config-mouse, I can't see any
changes that would break a serial mouse.

Comment 2 Agustin Barto 2005-07-01 02:38:02 UTC
Created attachment 116216 [details]
Output of cat /proc/bus/input/devices before modprobe sermouse; inputattach -bare /dev/ttyS0 --daemon

Comment 3 Agustin Barto 2005-07-01 02:38:59 UTC
Created attachment 116217 [details]
Output of cat /proc/bus/input/devices after modprobe sermouse; inputattach -bare /dev/ttyS0 --daemon

Comment 4 Agustin Barto 2005-07-01 02:43:55 UTC
I got my Microsoft Serial Mouse working with gpm and X.org adding the following
lines to my rc.local:

/sbin/modprobe sermouse
/usr/sbin/inputattach -bare /dev/ttyS0 --daemon

and modifying the configuration files to use /dev/input/mouse1 (instead of
/dev/input/mice). The idea came after examining the output of
/proc/bus/input/devices during the many tests I did.

I attached the output before and after calling the lines of above. I hope gives
someone an idea on were the problem is.

Comment 5 Samvinesh Christopher 2005-07-06 12:58:53 UTC
No need to change the rc.local.
Changing the DEVICE line alone in /etc/sysconfig/mouse with /dev/ttyS0 
worked for me.


Comment 6 Agustin Barto 2005-07-12 15:21:20 UTC
That only works AFTER you run gpm. The gpm rc script does basically the same as
I did. The computer with the problem doesn't have much ram so I can't have
useless daemons wasting memory.

Comment 7 Lúcio Fernando Diniz Cardoso 2005-08-13 18:26:16 UTC
I think FC4 is worst than FC3, I have many issues with this release that I
hadn't with FC3 (XP dual boot installation, sound and serial mouse among others).

Comment 8 Paul Nasrat 2005-09-14 22:29:45 UTC
Serial mice are not supported during install time with anaconda and for FC5
system-config-mouse is going away.


Note You need to log in before you can comment on or make changes to this bug.