Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160658 - update flex to 2.5.33?
Summary: update flex to 2.5.33?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: flex
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Machata
QA Contact:
URL:
Whiteboard:
: 190673 207416 223624 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 13:55 UTC by Joe Orton
Modified: 2015-05-05 01:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-24 17:38:29 UTC


Attachments (Terms of Use)

Description Joe Orton 2005-06-16 13:55:02 UTC
The flex-2.5.31 available from sourceforge has a number of nice features over
the current release in FC, like support for creating thread-safe parsers:

http://sourceforge.net/project/showfiles.php?group_id=72099

any chance of an update?

Comment 2 Petr Machata 2006-06-30 10:13:10 UTC
*** Bug 190673 has been marked as a duplicate of this bug. ***

Comment 3 Stefan Becker 2006-09-23 09:07:10 UTC
Just tried to rebuild the Mandriva 2007 xxdiff-3.2 SRPM for RHEL4 and found out
that a newer flex is required for this latest version:

flex  -PresParser resParser.l
"resParser.l", line 99: unrecognized %option: bison-bridge
"resParser.l", line 100: unrecognized %option: header-file

So a newer flex is required to compile at least some newer tool versions.

FYI: Mandriva 2007 provides flex 2.5.4a as "flex" RPM and flex 2.5.33 as
"flex-reentrant" RPM.

BTW: bug #207416 is a duplicate of this one.

Comment 4 Russell Cattelan 2006-09-25 05:06:24 UTC
*** Bug 207416 has been marked as a duplicate of this bug. ***

Comment 5 Petr Machata 2006-09-25 08:52:45 UTC
Current status... I intend to update flex to newer version.  I will do it post
FC-6 for rawhide, as it's hard to predict what can break with new flex.  I
personally use new flex for my day-to-day work for some time now, but I'd rather
play it safe.

Comment 6 Andre Costa 2006-12-22 15:50:27 UTC
I just checked and rawhide still offers flex 2.5.4a-41. Any ETA on an updated
flex? xxdiff [http://furius.ca/xxdiff/] can't be built with flex 2.5.4...

TIA

Comment 7 Petr Machata 2006-12-22 16:15:04 UTC
The things are underway, the plan is to do the transition in FC 7.  The first
step is to get compat-flex into distribution, more in bug 220381.  Currently it
seems it'll have to go to extras, which delays things a bit, as I'll have to
setup my account for extras.  Once it's here, I'll roll flex 2.5.33 for rawhide.

Comment 8 Petr Machata 2007-01-23 11:12:02 UTC
*** Bug 223624 has been marked as a duplicate of this bug. ***

Comment 9 Takanori MATSUURA 2007-01-23 11:34:24 UTC
Could anyone change the summary like to "update flex to 2.5.33?"?
The present one is too ambiguous.

Comment 10 Petr Machata 2007-01-24 17:38:29 UTC
I just built flex 2.5.33 for raw hide.  I'm already looking forward to all the
rejects-valid and accepts-invalid bugs that will pop up.  Enjoy!


Note You need to log in before you can comment on or make changes to this bug.