Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160645 - Crashes when installing extensions
Summary: Crashes when installing extensions
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 10:37 UTC by Alessandro Ronchi
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-13 20:15:44 UTC


Attachments (Terms of Use)
Strace log for this bug (deleted)
2005-06-24 00:49 UTC, Alessandro Ronchi
no flags Details

Description Alessandro Ronchi 2005-06-16 10:37:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; it-IT; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I try to install an extension for firefox (everyone, with every users and root), it crashes, without an error.
Maybe a permission problem?

Version-Release number of selected component (if applicable):
firefox-1.0.4-4

How reproducible:
Always

Steps to Reproduce:
1. open firefox
2. install extension

  

Actual Results:  Firefox crashed

Expected Results:  extension installed

Additional info:

Comment 1 Alessandro Ronchi 2005-06-24 00:49:48 UTC
Created attachment 115912 [details]
Strace log for this bug

Comment 2 Alessandro Ronchi 2005-07-22 08:28:07 UTC
The 1.0.6 version doesn't solve this problem.
I've tried also to remove my .mozilla* in home, but this doesn't solve the problem.

Maybe with a firefox debug version I could give more information, where can I
find a such thing for fedora linux-ppc?

Comment 3 Gerwin Krist 2005-07-31 12:48:20 UTC
I can say that installing extentions DOES work at my place with firefox-1.0.6-1.1.
Could you give a strace while running 1.06 version?

Comment 4 Gerwin Krist 2005-07-31 12:50:38 UTC
Just noticed your running on ppc, I ran it on a x86 box.

Comment 5 Andrew Overholt 2005-10-21 18:06:20 UTC
Firefox crashes on my ppc box upon installation of plugins as well (note:  the
plugins are there when I start up again).

Comment 6 John Thacker 2007-01-13 20:15:44 UTC
(This is a mass update of bugs which have been in the NEEDINFO state unmodified
for over a year and have not been confirmed for a still supported version of
Fedora Core.)

Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.


Note You need to log in before you can comment on or make changes to this bug.