Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160643 - pcap user is not added while installing tcpdump/arpwatch
Summary: pcap user is not added while installing tcpdump/arpwatch
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tcpdump
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 09:24 UTC by Kir Kolyshkin
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-21 09:22:45 UTC


Attachments (Terms of Use)
patch to tcpdump.spec adding prereq: /usr/sbin/{user,group}add to tcpdump and arpwatch (deleted)
2005-06-16 09:24 UTC, Kir Kolyshkin
no flags Details | Diff

Description Kir Kolyshkin 2005-06-16 09:24:58 UTC
Description of problem:

tcpdump and arpwatch tries to create user and group 'pcap' with UID/GID of 77 in
preinstall script, using /usr/sbin/useradd and /usr/sbin/groupadd.

In some situations it fails because useradd/groupadd binaries (from shadow-utils
rpm) is not yet installed. Proper fix would be to add
Prereq: /usr/sbin/useradd /usr/sbin/groupadd
to appropriate places of tcpdump.spec

Version-Release number of selected component (if applicable):
tcpdump-3.8.2-12


How reproducible:
Use yum to install tcpdump in a clean chroot environment. Say,

mkdir chrooted
yum --installroot chrooted tcpdump

Yum will pick up all dependencies correctly (including shadow-utils which is
required by some other rpm) and install everything. The problem is installation
order is not correct and tcpdump gets installed before shadow-utils.

I have checked that adding prereq for useradd and groupadd fixes the problem.
Patch to tcpdump.spec is attached.

Comment 1 Kir Kolyshkin 2005-06-16 09:24:58 UTC
Created attachment 115528 [details]
patch to tcpdump.spec adding prereq: /usr/sbin/{user,group}add to tcpdump and arpwatch


Note You need to log in before you can comment on or make changes to this bug.