Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160639 - Installer aborts with AttributeError: 'module' object has no attribute 'formatdate'
Summary: Installer aborts with AttributeError: 'module' object has no attribute 'forma...
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-16 08:49 UTC by Terrence Sue-Ako
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-06-16 22:40:48 UTC

Attachments (Terms of Use)

Description Terrence Sue-Ako 2005-06-16 08:49:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
An unhandled exception occurred during an installation update.  The following message appears after the 'Reading package information...' screen:

AttributeError: 'module' object has no attribute 'formatdate'

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot with FC4 install DVD and enter 'linux text' to start install.
2. Skip mediacheck (dvd was already media checked on this laptop and
another PC)
3. Select English then US for language, keyboard.
4. Select to install by upgrading current FC3 system on laptop (Fedora
Core 3  (/dev/VolGroup00/LogVol01))
5. Select 'Update boot loader configuration'
6. 'Reading package information...' appears
7. Generic blue screen with 'Welcome to Fedora Core' on line 1 and
'<Tab>/<Alt-Tab>...' on bottom line appears.  dvd drive makes
chuckling (head movement) sounds for a minute then above message

Actual Results:  Error message appeared and installation aborted.

Expected Results:  No message and installation update continued

Additional info:

1. both 'linux text' and 'linux text acpi=off' were tried.
2. both graphical and text (hit enter or enter 'linux text') tried.

error message:
An unhandled exception has occurred.  This is most likely a bug.
Please copy the full text of this exception and file a detailed bug
report against anaconda at

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1160, in ?,dispatch)
  File "/usr/lib/anaconda/", line 496, in run
  File "/usr/lib/anaconda/", line 174, in gotoNext
  File "/usr/lib/anaconda/", line 242, in moveStep
  File "/usr/lib/anaconda/", line 172, in readPackages
  File "/usr/lib/anaconda/", line 65, in readComps
    return self.readCompsViaMethod(hdlist)
  File "/usr/lib/anaconda/", line 106, in readCompsViaMethod
    return groupSetFromCompsFile(fname,hdlist)
  File "/usr/lib/anaconda/", line 923, in
  File "/usr/lib/python2.4/site-packages/urlgrabber/", line
  444, in urlopen
    return default_grabber.urlopen(url,**kwargs)
  File "/usr/lib/python2.4/site-packages/urlgrabber/", line
  575, in urlopen
    return self._retry(opts,retryfunc,url)
  File "/usr/lib/python2.4/site-packages/urlgrabber/", line
  547, in _retry
    return apply(func,(opts,) + args, {})
  File "/usr/lib/python2.4/site-packages/urlgrabber/", line
  574, in retryfunc
    return URLGrabbberFileObject(url, filename=None, opts=opts)
  File "/usr/lib/python2.4/site-packages/urlgrabber/", line
  727, in __init__
  File "/usr/lib/python2.4/site-packages/urlgrabber/", line
  794, in _do_open
  File "/usr/lib/python2.4/site-packages/urlgrabber/", line
  885, in _make_request
  File "/usr/lib/python2.4/", line 358, in open
  File "/usr/lib/python2.4/", line 376, in _open
  File "/usr/lib/python2.4/", line 337, in _call_chain
  File "/usr/lib/python2.4/", line 1119, in file_open
    return self.open_local_file(req)
  File "/usr/lib/python2.4/", line 1137, in open_local_file
AttributeError: 'module' object has no attribute 'formatdate'

Comment 1 Terrence Sue-Ako 2005-06-16 08:51:53 UTC
Install was attempted on a Dell Latitude CPiR with:
 Pentium II-400 MHz
 256mb memory
 NeoMagic 2360 video/audio controller
 60064 mb hard drive
 dual boot with
  Windows 2000 on first partition
  FC3 /boot using GRUB on second partition
  linux lvm on third partition

Comment 2 Jeremy Katz 2005-06-16 20:26:43 UTC
Can you provide the complete traceback you received?

Comment 3 Terrence Sue-Ako 2005-06-16 20:56:47 UTC
The error message above is the complete text of what was displayed.  It may
contain typos, as I copied it by reading the message and typing it into my other

I have to confess that I am a bit perplexed now.  Although I was able to
duplicate the error literally 5 times running last night, I cannot do that now.
 I get a similar but different message.

Unless you have any other comment, I would like to close the bug for now and
await further investigation.  I suspect that there may be some hardware related
problem because I have not changed anything as far as I can tell.

Comment 4 Terrence Sue-Ako 2005-06-16 22:40:48 UTC
I am closing the bug report.  Error warning has now changed (3 straight times)
to 'OSError: [Errno 8] Exec format error'.  <alt-f4> shows several entries
indicating medium error.  I believe I have a hardware problem.

Note You need to log in before you can comment on or make changes to this bug.