Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160636 - unable to display russian characters in console
Summary: unable to display russian characters in console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhgb
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 156322 Russian
TreeView+ depends on / blocked
 
Reported: 2005-06-16 08:28 UTC by Lawrence Lim
Modified: 2014-03-26 00:52 UTC (History)
3 users (show)

Fixed In Version: RHBA-2005-714
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-05 17:23:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:714 qe-ready SHIPPED_LIVE rhgb bug fix update 2005-10-05 04:00:00 UTC

Description Lawrence Lim 2005-06-16 08:28:30 UTC
Description of problem:
When I am in run level 5, tried to do init 3 then init 5, the russian messages
on the console is not readable.

Version-Release number of selected component (if applicable):
initscripts-7.93.13.EL-2

How reproducible:
Always

Steps to Reproduce:
1.reboot with LANG=ru_RU.UTF-8 in /etc/sysconfig/i18n into runlevel 5
2.at gdm, ctrl-alt-f1
3.init 3
  
Actual results:
russian characters cannot be displayed properly

Expected results:
russian characters can be displayed

Additional info:

Comment 1 Bill Nottingham 2005-06-16 19:29:15 UTC
I can't reproduce this. Switching to VT1 and running 'telinit 3'; I can then see
Russian in, say, the pango HELLO.utf8 file, or by running 'service sshd restart'.

(Well, it's cyrillic. I can only assume it's russian.)

Comment 2 Lawrence Lim 2005-06-17 01:05:12 UTC
What about VT8? Is the information displaying properly as well?

Comment 3 Bill Nottingham 2005-06-17 18:09:29 UTC
So, this happens because rhgb is in use.

If this is to work, either rhgb or gdm needs to initialize the VT that X grabbed
(7 or 8) into unicode mode. (See /bin/unicode_start, for example.)


Comment 4 Leon Ho 2005-07-25 03:59:09 UTC
Russian main feature is ACKed (bug 130962), but it is missing acks on this
individual bug. Confirmed with PM/QA/Devel stakeholders on adding back the
missing acks and add to U2CanFix tracker.

Comment 9 Ray Strode [halfline] 2005-08-02 21:03:55 UTC
So I've investigated this a bit.  GDM doesn't really play into the picture at
all.    I've got a fix for rhgb that seems to solve the problem.  I just need to
clean it up.

Note when rhgb finishs it calls /sbin/change_console -r so the init messages
should be going back to tty1.  They're not.  That might be an init bug.

Comment 10 Ray Strode [halfline] 2005-08-03 06:49:13 UTC
Marking MODIFIED for QA.

Comment 11 Red Hat Bugzilla 2005-10-05 17:23:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-714.html



Note You need to log in before you can comment on or make changes to this bug.