Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160624 - Installation fails because ns-slapd listens to IPv6 address only
Summary: Installation fails because ns-slapd listens to IPv6 address only
Keywords:
Status: CLOSED DUPLICATE of bug 213626
Alias: None
Product: 389
Classification: Retired
Component: Install/Uninstall
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Noriko Hosoi
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 06:23 UTC by Bjoern Engels
Modified: 2015-01-04 23:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-06 20:38:58 UTC


Attachments (Terms of Use)

Description Bjoern Engels 2005-06-16 06:23:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
During installation ns-slapd does not bind to 0.0.0.0:389 when you don't want to use v6 mapped v4 addresses and you set net.ipv6.bindv6only=1. 

Version-Release number of selected component (if applicable):
fedora-ds-7.1-2.RHEL4

How reproducible:
Always

Steps to Reproduce:
1. sysctl -w net.ipv6.bindv6only=1
2. run setup
3. check netstat output
  

Actual Results:  ds_setup tries to connect to 127.0.0.1:389

Expected Results:  ns-slapd should bind to 0.0.0.0:389

Additional info:

sysctl -w net.ipv6.bindv6only=0 works around this problem

Comment 2 To Ngan 2006-12-12 22:51:45 UTC
*** Bug 164163 has been marked as a duplicate of this bug. ***

Comment 3 Rich Megginson 2007-09-06 20:01:42 UTC
Noriko, this is resolved, right?

Comment 4 Noriko Hosoi 2007-09-06 20:38:58 UTC
(In reply to comment #3)
> Noriko, this is resolved, right?

Yep, marked duplicate of 213626 "start-slapd fails if nsslapd-listenhost is
specified (multihomed, FDS 1.0.3)"

*** This bug has been marked as a duplicate of 213626 ***


Note You need to log in before you can comment on or make changes to this bug.