Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160609 - Mention LDIF v1 req'd when using :< URL specifier notation in CLI doc
Summary: Mention LDIF v1 req'd when using :< URL specifier notation in CLI doc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: Doc-config-command-file-reference
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: DS8.1
: ---
Assignee: Deon Ballard
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 01:35 UTC by Ulf Weltman
Modified: 2015-01-04 23:18 UTC (History)
2 users (show)

Fixed In Version: 8.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-15 21:52:27 UTC


Attachments (Terms of Use)

Description Ulf Weltman 2005-06-16 01:35:53 UTC
Description of problem:
Reading attributes values from a file when running the ldapmodify CLU has been
tripping up people for a while.  The "jpegphoto:< file:///tmp/whee.jpg" method
only works if the LDIF is v1 or later, that is, it contains the line "version:
1".  Otherwise the actual file URL is added as the value.  A note about this in
the CLI doc on PDF page 240 would be useful, not sure if there are other
appropriate spots.

By the way, maybe a "Documentation" component would be useful in Bugzilla? 
There is a "UI - Online Help" but that's different...

Version-Release number of selected component (if applicable):
7.1

How reproducible:
...always

Steps to Reproduce:
1. Read CLI doc, page 240
  
Actual results:
Confusion!

Expected results:
Enlightenment!

Additional info:

Comment 3 Chandrasekar Kannan 2007-10-18 06:30:01 UTC
change priority=medium. these docs are not a high priority for the 8.0 release.

Comment 4 David O'Brien 2007-10-24 01:30:44 UTC
Not critical for 8.0 GA so pushing to 8.1. Reassign all Config, Command, File
Ref to bforte.

Comment 6 Deon Ballard 2008-01-09 03:29:48 UTC
Done. 
Text:
"NOTE: The :< URL specifier notation only works if LDIF statement is version 1
or later, meaning version: 1 is used with the ldapmodify command. Otherwise, the
actual file is appended as the attribute value rather than the binary data."

Link:
http://engineering.redhat.com/docbot/en-US/Red_Hat_Directory_Server/8.0/html/Configuration_Command_File_Reference/Configuration_Command_File_Reference-Command_Line_Utilities-ldapmodify.html#Configuration_Command_File_Reference-ldapmodify_Options-Additional_ldapmodify_Options

I also added the note to the :< URL specifier part for the ldif tool. Is that
right? Does that enlighten or cloud?

Comment 7 Ulf Weltman 2008-01-09 07:56:42 UTC
It's the file URL that gets appended as the attribute value rather than the
contents of the file (which might be binary, ASCII, or whatever, not necessarily
the jpeg from the example).

"NOTE: The :< URL specifier notation only works if LDIF statement is version 1
or later, meaning version: 1 is inserted in the LDIF. Otherwise, the
actual file URL is appended as the attribute value rather than the file's contents."


Comment 8 Deon Ballard 2008-01-09 17:18:13 UTC
Thanks, Ulf. I corrected the notes per your changes.

This link is the same as in comment #6.


Comment 9 Deon Ballard 2008-01-10 05:51:43 UTC
*** Bug 164167 has been marked as a duplicate of this bug. ***

Comment 10 Deon Ballard 2008-02-15 21:52:27 UTC
CLosing review bugs and content bugs that were fixed in the 8.0 release for the
install, admin, and CLI guides.


Note You need to log in before you can comment on or make changes to this bug.