Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160604 - /sbin/ide_info missing, automount fails
Summary: /sbin/ide_info missing, automount fails
Keywords:
Status: CLOSED DUPLICATE of bug 120486
Alias: None
Product: Fedora
Classification: Fedora
Component: pcmcia-cs
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-16 00:19 UTC by Jonathan S. Shapiro
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-29 23:03:28 UTC


Attachments (Terms of Use)

Description Jonathan S. Shapiro 2005-06-16 00:19:24 UTC
I have a cardbus to CF adaptor. Under FC3, insertion of the adaptor (with CF
card) would cause automount and a new icon on desktop.

Under FC4, an attempt is made to do this, but it fails. An error is recorded in
/var/log/messages claiming that /sbin/ide_info was not found. "yum provides"
does not reveal any package that supplies any ide_info binary (though there does
appear to be a residual man page in japanese :-) Attempt to mount gets as far as
creating the mount point but does not actually do the mount.

Not clear if absence of ide_info is causally related to failure to mount.

If I log out and log back in, the icon still does not appear, but the device
*does* get mounted.

Comment 1 Jonathan S. Shapiro 2005-06-16 00:20:14 UTC
Hmm. On second thought this is *probably* an automounter issue. I put it here
because the complaint came from cardmgr. If I got it wrong, my apologies

Comment 2 Pete Zaitcev 2005-06-16 00:49:45 UTC
I am sure this has nothing to do with missing /sbin/ide_info.
It is not used on FC4 and I have removed the call to it, so you
won't be seing that message in future versions of pcmcia_cs.

That said, perhaps something is not right with HAL or Nautilus
on your box. The automatic mounting must be enabled explicitly in
this dialog:
 Gnome menu -> Desktop -> Preferences -> Removable Drives and Media

That the device gets mounted at login is very strange.
Maybe David has any ideas...

What is the precise version of pcmcia_cs on your box, by
 rpm -q pcmcia_cs
?

Comment 3 David Zeuthen 2005-06-16 01:46:52 UTC
This might be bug 159748 which is about gnome-vfs not getting an event when
/etc/mtab - does mount(1) tell if the device is mounted?

Comment 4 David Zeuthen 2005-06-16 01:49:11 UTC
Btw, an update for gamin is available as an update

 http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/SRPMS/

That might fix the problem if my guess in comment 3 is correct.

Comment 5 John Thacker 2006-10-29 23:03:28 UTC

*** This bug has been marked as a duplicate of 120486 ***


Note You need to log in before you can comment on or make changes to this bug.