Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160593 - Post-install script calls gtk-update-icon-cache which isn't required by spec file
Summary: Post-install script calls gtk-update-icon-cache which isn't required by spec ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-services
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
: 160594 160596 160597 160598 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 23:38 UTC by Albert Strasheim
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-16 12:31:49 UTC


Attachments (Terms of Use)

Description Albert Strasheim 2005-06-15 23:38:44 UTC
Description of problem:

Post-install script calls gtk-update-icon-cache but package doesn't require
/usr/bin/gtk-update-icon-cache or gtk2.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Nils Philippsen 2005-06-16 12:31:49 UTC
This is intentional. The %post script checks whether
/usr/bin/gtk-update-icon-cache is present and executable and runs it only if
this is the case. Ideally, /usr/bin/gtk-update-icon-cache would be run only once
after all packages have been installed but this is not really doable with RPM as
it is.  

Comment 2 Nils Philippsen 2005-06-16 12:33:17 UTC
*** Bug 160594 has been marked as a duplicate of this bug. ***

Comment 3 Nils Philippsen 2005-06-16 12:33:28 UTC
*** Bug 160596 has been marked as a duplicate of this bug. ***

Comment 4 Nils Philippsen 2005-06-16 12:33:40 UTC
*** Bug 160597 has been marked as a duplicate of this bug. ***

Comment 5 Nils Philippsen 2005-06-16 12:33:51 UTC
*** Bug 160598 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.