Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160573 - FC4 does not install to PPC LPAR: --virtpconsole: unknown option
Summary: FC4 does not install to PPC LPAR: --virtpconsole: unknown option
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: powerpc
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
: 161206 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 21:02 UTC by Dustin Kirkland
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-29 21:46:43 UTC


Attachments (Terms of Use)
Fixed anaconda (deleted)
2005-06-16 15:16 UTC, Paul Nasrat
no flags Details
python problem using new anaconda (deleted)
2005-07-12 15:50 UTC, Mark Smith
no flags Details

Description Dustin Kirkland 2005-06-15 21:02:32 UTC
Description of problem:
FC4 is not installable to IBM PPC logical partitions.

How reproducible:
Steps to Reproduce:
1. Attempt to install to IBM PPC LPAR
  
Actual results:
Running anaconda, the Fedora Core system installer - please wait...
Error bad argument --virtpconsole: unknown option

:install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /mnt/source done
        /selinux done
you may safely reboot your system


Expected results:
Installation to proceed normally

Additional info:
I've tried a handful of install kernel options, to no avail, including:
console=hvc0 vnc askmethod

Comment 1 Nikita Shulga 2005-06-16 13:23:47 UTC
Same story with IBM JS-20 BladeCenter

Comment 2 Paul Nasrat 2005-06-16 15:16:39 UTC
Created attachment 115546 [details]
Fixed anaconda

Typo - fixed on fc4 branch.  I can give instructions for an
updates.img/RHupdates - what type of install are you doing (nfs, nfs + iso,
http, CD?)

Comment 3 Nikita Shulga 2005-06-16 19:47:23 UTC
I'll be very appreciative, if you can give me simple instructions on how to do this. I'm planing to use nfs + 
iso kind of installation.
And thanks in advance for fast responce.

Comment 4 Dustin Kirkland 2005-06-16 19:55:47 UTC
I would like:
1) install entirely from CDs
2) boot from disc 1, point to NFS

Comment 5 Paul Nasrat 2005-06-16 19:59:33 UTC
How to create updates.img:

https://www.redhat.com/archives/anaconda-devel-list/2003-September/msg00093.html

mount then cp the file onto the disk into a flat dir structure.

For nfs iso:

'updates.img' file in 'Fedora/base' directory

For nfs exploded tree:

Create a dir called RHupdates parallel to Fedora (top level dir). and drop the
anaconda replacement file there.

Best of luck

Comment 6 Nikita Shulga 2005-06-21 11:58:21 UTC
Thanks! That helped to fix this problem. But a new one occured:
Anaconda shows following graffiti:
                  +----------------+ Error +-----------------+
                  |                                          |
                  | Error opening /tmp/sda: No medium found  |
                  |                                          |
                  |      +-------+          +--------+       |
                  |      | Retry |          | Cancel |       |
                  |      +-------+          +--------+       |
                  |                                          |
                  |                                          |
                  +------------------------------------------+
And after a few cancels we end up with this:
         +------------+ No Drives Found +-------------+
                 |                                            |
                 | An error has occurred - no valid devices   |
                 | were found on which to create new file     |
                 | systems. Please check your hardware for    |
                 | the cause of this problem.                 |
                 |                                            |
                 |                  +----+                    |
                 |                  | OK |                    |
                 |                  +----+                    |
                 |                                            |
                 |                                            |
                 +--------------------------------------------+


Comment 7 Chris Lumens 2005-06-21 13:50:11 UTC
*** Bug 161206 has been marked as a duplicate of this bug. ***

Comment 8 dewt 2005-07-01 16:00:22 UTC
this error also occurs for systems without LPAR enabled but have their console
set to the serial port.

Comment 9 Paul Nasrat 2005-07-01 16:55:19 UTC
Due to the code paths in anaconda this bug (really just a typo) will affect all
non mac ppc hardware, please confirm if using an updates.img/RHupdates fixes it
for you.

Comment 10 Mark Smith 2005-07-12 15:50:42 UTC
Created attachment 116662 [details]
python problem using new anaconda

on power5 with VIOserver disks: sda=20GB and sdb=146GB (whole real disk
allocated from server),
using CD1 to boot, I can access patched nfs install sources.
When installation starts, I hit attached python problem during disk format part
of install. 
> File "/mnt/source/RHupdates/anaconda", line 1160, in ?
    intf.run(id, dispatch)
... that anaconda file is a copy of the patch Paul posted.
Is this a new bug, or something needing correction in the existing patch?

Comment 11 Paul Nasrat 2005-07-12 16:07:37 UTC
Mark in future can you attach logs as plain ascii text rather than rtf.

This looks to be a seperate issue - what partitioning scheme were you using? Is
this reproducible?


Comment 12 Mark Smith 2005-07-12 16:17:58 UTC
Hi Paul, yes will make future attaches txt.
Was using all defaults, so "autopartition".
I've not tried recreating it. Didn't know if you'd want some info from python 
or another tool before rebooting.  It's still at the python prompt.
So please assist me with some suggested debugging steps (ctrl-z, command line 
prompt, go get contents of some log, etc) (or email me offline). 
I will open a new bug for this different problem.
Thanks.

Comment 13 Sean Dogar 2005-07-13 23:44:01 UTC
I'm having this same bug on an IBM JS20 blade.  I want to do an FC4 install from
CD, and anaconda bombs every time.  I'm confused as to what the solution to this
bug is...I take it I need to fix the anaconda that's on the FC4 install CD and
reburn the disc.  Can someone elaborate on this for me?

Comment 14 Torsten 2005-07-25 14:12:56 UTC
Hi folks,

I can agree. It does not work on a JS20. The "updates.img" workaround runs fine.
But the " Error opening /tmp/sda: No medium found" issue is still available.
I have already seen this error when installing a RHEL4 via SOL or serial console
and I "fixed" it with installing via VNC. But this does not work with Fedora.
Can anybody give some informations how to sail round this issue?

Thanks,

Torsten

Comment 15 Torsten 2005-07-25 14:14:26 UTC
Hi folks,

I can agree. It does not work on a JS20. The "updates.img" workaround runs fine.
But the " Error opening /tmp/sda: No medium found" issue is still available.
I have already seen this error when installing a RHEL4 via SOL or serial console
and I "fixed" it with installing via VNC. But this does not work with Fedora.
Can anybody give some informations how to sail round this issue?

Thanks,

Torsten

Comment 16 ale.prete 2005-10-05 14:06:35 UTC
Has someone resolved this problems of FC4 in a complete and satisfactory way?

Thanks,
  Alessandro


Comment 17 Paul Nasrat 2005-10-05 14:11:53 UTC
There is an unofficial updated fedora ppc tree here:

ftp://zeniv.uk.linux.org/pub/people/dwmw2/fc4-pegasos


Note You need to log in before you can comment on or make changes to this bug.