Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160572 - %configure macro uses libdir of /usr/lib64 for target i386
Summary: %configure macro uses libdir of /usr/lib64 for target i386
Keywords:
Status: CLOSED DUPLICATE of bug 233145
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 20:48 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-10 19:22:52 UTC


Attachments (Terms of Use)

Description Need Real Name 2005-06-15 20:48:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When using "rpmbuild --target i386" on a spec file which uses the %configure macro, the macro expands on the x86_64 to pass ./configure an argument of "--libdir=/usr/lib64"  When the target platform is any 32 bit arch (i386, i586, i686, athlon, etc.) then the libdir should be set to /usr/lib

Version-Release number of selected component (if applicable):
rpm-devel-4.4.1-21

How reproducible:
Always

Steps to Reproduce:
1.Install FC4 x86_64
2.Take any spec file which uses the %configure macro in the %build section
3.Run rpmbuild --target i386 against the spec file and then watch for what the macro expands to
  

Actual Results:  ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info

Expected Results:   ./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info

Additional info:

Comment 1 Jeff Johnson 2005-09-29 19:53:16 UTC
This is a cross compilation problem. Redefine %configure to taste, the default value for %configure is 
unlikely to make you happy.

Comment 2 David Woodhouse 2007-04-10 19:19:02 UTC
Bug still exists. %_libdir is set according to the contents of /etc/rpm/platform
not --target argument.

Comment 3 David Woodhouse 2007-04-10 19:22:52 UTC
OTOH bug 233145 has a supposedly fixed package, so closing as a dupe of that
even though it's newer.

*** This bug has been marked as a duplicate of 233145 ***


Note You need to log in before you can comment on or make changes to this bug.