Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160570 - Starting rpc.svcgssd in nfs init script makes rpcsvcgssd init unnecessary?
Summary: Starting rpc.svcgssd in nfs init script makes rpcsvcgssd init unnecessary?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 165066
TreeView+ depends on / blocked
 
Reported: 2005-06-15 20:32 UTC by Wesley Harrell
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.0.7-9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 07:32:06 UTC


Attachments (Terms of Use)

Description Wesley Harrell 2005-06-15 20:32:44 UTC
Description of problem:
According to the changelog in nfs-utils-1.0.6-52 the developer
"Changed the nfs.init script to bring rpc.svcgssd up and down,
  since rpc.svcgssd is only needed with the NFS server is running."

However the rpcsvcgssd init script is still added via chkconfig during install
*and* is started before nfs. Is this a mistake, or is there a reason the
rpcsvcgssd continues to be started through its own init script? 

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-52
but this also persists through latest fc4 version nfs-utils-1.0.7-8


How reproducible:

Install nfs-utils.  rpcsvcgssd persists in chkconfig as a startable service 
even if nfs is not started, or before nfs starts.


Steps to Reproduce:
1. install nfs-utils-1.0.6-52 or later

  
Actual results:

rpcsvcgssd is added to chkconfig as seperate service, and is started 
via nfs init script


Expected results:

start rpcsvcgssd in nfs init script only?

Additional info:

Comment 1 Steve Dickson 2005-06-16 13:22:14 UTC
This should be fixed in nfs-utils-1.0.7-9 


Note You need to log in before you can comment on or make changes to this bug.