Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160560 - Toolbar bookmarks 'disappear' from right-hand side until window is moved
Summary: Toolbar bookmarks 'disappear' from right-hand side until window is moved
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard: FF3RawhideClose
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 20:00 UTC by Kyle R Maxwell
Modified: 2018-04-11 17:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-20 16:46:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 280773 None None None Never

Description Kyle R Maxwell 2005-06-15 20:00:24 UTC
I use the bookmarks toolbar for my most-frequently-used bookmarks, and as stuff
gets occasionally added to it, it grows to the point that bookmarks on the
right-hand side don't appear without using the drop-down tool.

After some time, of course, I go clean things up so that everything should fit
on the toolbar without needing the drop-down tool using the Manage Bookmarks
window. But even once those are fixed, whichever bookmarks were pushed off still
are not re-drawn on the toolbar until the window is resized, even by one pixel.

Reproduce by:
1. Add sufficient bookmarks with sufficiently long names that not all of them
can appear at once on the toolbar, but instead are pushed into a drop-down on
the right side.
2. Using 'Manage Bookmarks', rename some of these with smaller names so that
everything should fit on the toolbar.
3. Note that even though the bookmarks that were originally shown on the toolbar
are still there albeit with shorter names, those that were in the drop-down will
not get drawn on the toolbar itself until the windoww is slightly resized.

I'm seeing this under i386 but am fairly confident that this is not an
architecture-specific bug.

I have not been able to access the Mozilla Bugzilla to file a similar bug there
but a query there didn't appear to locate the same problem.

Comment 1 Kyle R Maxwell 2005-06-15 20:22:01 UTC
On digging further, this appears to be the same as Mozilla bug #280773.

Comment 2 Matěj Cepl 2007-12-20 16:46:49 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.