Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160554 - GTK+-based applications does not show "�" character correctly
Summary: GTK+-based applications does not show "�" character correctly
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 19:33 UTC by Dawid Gajownik
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-28 21:49:21 UTC


Attachments (Terms of Use)
Screenshot of the XMMS (deleted)
2005-06-15 19:42 UTC, Dawid Gajownik
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 4366 None None None Never

Description Dawid Gajownik 2005-06-15 19:33:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b) Gecko/20050217

Description of problem:
"£" and "³" characters are not shown correctly in gtk+-based apps (XMMS, mplayer, etc.). They are rendered as brackets: "£" as "()" and "³" as "))"

Version-Release number of selected component (if applicable):
gtk+-1.2.10-39

How reproducible:
Always

Steps to Reproduce:
1. LANG=pl_PL.UTF-8 xmms
2. Go to the menu

Additional info:

This bug is also visible in FC3. IIRC, in FC2 everything was OK.

Comment 1 Dawid Gajownik 2005-06-15 19:42:23 UTC
Created attachment 115501 [details]
Screenshot of the XMMS

I had to attach screenshot, because mentioned characters are wrongly rendered
in the webbrowser ;-)

Comment 2 Matthias Clasen 2005-06-21 17:30:02 UTC
The right fix is to port whatever application is still using gtk 1.2 to
gtk 2.x, which offers MUCH better internationalization

Comment 3 Dawid Gajownik 2005-09-28 17:12:46 UTC
No way ;-) I've found the patch, so you can now easyly fix it â
https://bugs.freedesktop.org/show_bug.cgi?id=4366

Comment 4 Mike A. Harris 2005-09-28 21:49:21 UTC
We definitely will not apply that patch, as it is incorrect, however
once someone has implemented the solution suggested by Owen Taylor
in the bug report referenced in comment #3, and it gets checked
into Xorg CVS and does not cause any regressions, we will review
it for consideration in a future update.



Note You need to log in before you can comment on or make changes to this bug.