Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160549 - Core 4 lacks compat-libstdc++-devel and libstdc++-libc6.2-2.so.3
Summary: Core 4 lacks compat-libstdc++-devel and libstdc++-libc6.2-2.so.3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-gcc
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 18:52 UTC by Robert Williams
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-16 14:26:37 UTC


Attachments (Terms of Use)

Description Robert Williams 2005-06-15 18:52:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
Gaussian Inc. provides a program named GaussView for
Linux - only in executable form.  This program requires
libstdc++-libc6.2-2.so.3.   I see this when I run gview:

[daksh@cpmd ~]$ gview
//usr/local/gv/gview: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory

libstdc++-libc6.2-2.so.3 is provided by compat-libstdc++-devel in earlier
versions of Fedora Core 2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install gview
2. Run gview
3.
  

Actual Results:  See above.  libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory

Expected Results:  gview should run and present a graphical interface.

Additional info:

Workaround is to copy libstdc++-libc6.2-2.so.3 
from some other system (Fedora Core 2 or earlier)
to the Core 4 machine.

Comment 1 Jakub Jelinek 2005-06-16 14:26:37 UTC
compat-libstdc++-devel* has been dropped, because there is no point to keep
many compat packages around.  The files to build against compatibility libstdc++
are included together with the compatibility C++ compiler in compat-gcc-c++-32,
the compatibility libstdc++ shared library in compat-libstdc++-33.
libstdc++-libc6.2-2.so.3 (GCC 2.96-RH libstdc++) is provided in
compat-libstdc++-296.




Note You need to log in before you can comment on or make changes to this bug.