Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160533 - kernel-devel should be installed for both SMP and UP kernels
Summary: kernel-devel should be installed for both SMP and UP kernels
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 16:32 UTC by Dimitri Papadopoulos
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 15:10:59 UTC


Attachments (Terms of Use)

Description Dimitri Papadopoulos 2005-06-15 16:32:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
On an SMP machine, the "kernel-devel" package for the UP kernel is missing. I would expect the "kernel-devel" packages to be installed for both UP and SMP kernels as is the case with all previous Fedora releases - or the UP kernel not to be installed at all.


Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 on an SMP machine
2. rpm -qa | fgrep kernel
3. ls -l /lib/modules/2.6.11-1.1369_FC4/build


Actual Results:  # rpm -qa | fgrep kernel
kernel-2.6.11-1.1369_FC4
kernel-smp-devel-2.6.11-1.1369_FC4
kernel-smp-2.6.11-1.1369_FC4
# 


Expected Results:  # rpm -qa | fgrep kernel
kernel-2.6.11-1.1369_FC4
kernel-devel-2.6.11-1.1369_FC4
kernel-smp-devel-2.6.11-1.1369_FC4
kernel-smp-2.6.11-1.1369_FC4
# 


Additional info:

Comment 1 Jeremy Katz 2005-07-06 15:10:59 UTC
This is actually due to a stupid bug in the logic in the installer for
installing kernel-devel.  It was only getting selected if we didn't install
kernel-smp.

Oops, fixed in CVS for FC5


Note You need to log in before you can comment on or make changes to this bug.