Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1605232 - REGRESSION: Installer (prerequisites playbook) pulls cri-o:latest image instead of the correct version
Summary: REGRESSION: Installer (prerequisites playbook) pulls cri-o:latest image inste...
Keywords:
Status: CLOSED DUPLICATE of bug 1614916
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.9.z
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-20 13:51 UTC by Wolfgang Kulhanek
Modified: 2018-08-15 17:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-15 17:19:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wolfgang Kulhanek 2018-07-20 13:51:13 UTC
Description of problem:

The prerequisites playbook pre-pulls cri-o:latest image to all the nodes. It appears that the latest version of this image is either broken or does not work with 3.9. Regardless the install now fails with nodes not being able to start up. There was a new image pushed 2 days ago which now seems to cause the failure.

This is similar - but NOT duplicate - to https://bugzilla.redhat.com/show_bug.cgi?id=1599605

Version-Release number of the following components:
This happens on 3.9.31 and 3.9.33 (and I suspect earlier versions as well but didn't test).

How reproducible:

Every time.

Steps to Reproduce:
1. Install OCP with CRI-O enabled
2. Install fails

Actual results:
journalctl -xe shows this:

kuberuntime_manager.go:172] Get runtime version failed: rpc error: code = Unimplemented desc = unknown service runtime.RuntimeService
Jul 20 08:45:26 master1.wk33.internal atomic-openshift-node[47894]: F0720 08:45:26.442358   47894 server.go:173] failed to run Kubelet: failed to create kubelet: rpc error: code = Unimplemented desc = unknown service runtime.RuntimeServ
Jul 20 08:45:26 master1.wk33.internal systemd[1]: atomic-openshift-node.service: main process exited, code=exited, status=255/n/a



Expected results:

Additional info:

Comment 2 Scott Dodson 2018-08-15 17:19:38 UTC

*** This bug has been marked as a duplicate of bug 1614916 ***


Note You need to log in before you can comment on or make changes to this bug.