Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160523 - can't activate prism54 card at bootup
Summary: can't activate prism54 card at bootup
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 15:46 UTC by Eric Tanguy
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-29 10:06:17 UTC


Attachments (Terms of Use)

Description Eric Tanguy 2005-06-15 15:46:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When the system try to activate the prism54 card at boot, it fails with this in dmesg : 
eth0: uploading firmware...
audit(1118835134.219:31): avc:  denied  { write } for  pid=1910
comm="firmware.agent" name=loading dev=sysfs ino=6188
scontext=system_u:system_r:hotplug_t tcontext=system_u:object_r:sysfs_t
tclass=file
audit(1118835134.219:32): avc:  denied  { write } for  pid=1910
comm="firmware.agent" name=loading dev=sysfs ino=6188
scontext=system_u:system_r:hotplug_t tcontext=system_u:object_r:sysfs_t
tclass=file
audit(1118835134.219:33): avc:  denied  { search } for  pid=1912
comm="cp" name=selinux dev=dm-0 ino=27656630
scontext=system_u:system_r:hotplug_t
tcontext=system_u:object_r:selinux_config_t tclass=dir
audit(1118835134.220:34): avc:  denied  { write } for  pid=1912
comm="cp" name=data dev=sysfs ino=6193
scontext=system_u:system_r:hotplug_t tcontext=system_u:object_r:sysfs_t
tclass=file
audit(1118835134.220:35): avc:  denied  { write } for  pid=1910
comm="firmware.agent" name=loading dev=sysfs ino=6188
scontext=system_u:system_r:hotplug_t tcontext=system_u:object_r:sysfs_t
tclass=file
audit(1118835134.220:36): avc:  denied  { write } for  pid=1910
comm="firmware.agent" name=loading dev=sysfs ino=6188
scontext=system_u:system_r:hotplug_t tcontext=system_u:object_r:sysfs_t
tclass=file
prism54: request_firmware() failed for 'isl3890'
eth0: could not upload firmware ('isl3890')
eth0: islpci_reset: failure

The card can be activated without any problem during a session and the isl3890 file is in /lib/firmware

If i disable selinux, the card is activated at boot time.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1.Reboot the system
2.the system can't activate the wireless card at bootup
3.
  

Additional info:

Comment 1 Eric Tanguy 2005-06-21 18:25:08 UTC
In fact if i activate selinux but disable enforcing application the prism54
wireless card is activated at boot

Comment 2 Daniel Walsh 2005-06-26 11:47:09 UTC
Fixed in selinux-policy-targeted-1.23.18-12

Comment 3 Eric Tanguy 2005-07-02 10:07:08 UTC
i still have problem to enable enforcing mode and enable the prism54 card at
boot up.

Comment 4 Daniel Walsh 2005-07-02 19:43:21 UTC
What avc messages are you seeing with 1.23.18-12?  17 has been released, is that
any better?

Comment 5 Eric Tanguy 2005-07-07 18:30:12 UTC
All is fine enabling selinux but disabling enforcing mode. If i enable enforcing
mode i obtain no error message except : no such file or directory as the system
could not access the firmware file. After i can log and activate manually the
device without any problem.

Comment 6 Eric Tanguy 2005-07-14 07:49:54 UTC
I still have the same problem with the new selinux-policy-targeted-1.25.1-9

Comment 7 Daniel Walsh 2005-07-14 14:13:29 UTC
Any avc messages in /var/log/messages?  /var/log/audit/audit.log?

Comment 8 Eric Tanguy 2005-07-17 15:57:45 UTC
Here is the lines i found in /var/log/messages :
Jul 17 17:46:56 bureau kernel: audit(1121615214.230:2): avc:  denied  { search }
for  pid=1782 comm="cp" name="selinux" dev=dm-0 ino=27656630
scontext=system_u:system_r:hotplug_t tcontext=system_u:object_r:selinux_config_t
tclass=dir
Jul 17 17:46:56 bureau kernel: audit(1121615214.237:3): avc:  denied  {
sys_rawio } for  pid=1782 comm="cp" capability=17
scontext=system_u:system_r:hotplug_t tcontext=system_u:system_r:hotplug_t
tclass=capability
Jul 17 17:46:56 bureau kernel: prism54: request_firmware() failed for 'isl3890'
Jul 17 17:46:56 bureau kernel: eth0: could not upload firmware ('isl3890')
Jul 17 17:46:56 bureau kernel: eth0: islpci_reset: failure
Jul 17 17:46:56 bureau kernel: audit(1121615214.293:4): avc:  denied  {
sys_tty_config } for  pid=1779 comm="ip" capability=26
scontext=system_u:system_r:ifconfig_t tcontext=system_u:system_r:ifconfig_t
tclass=capability


Comment 9 Eric Tanguy 2005-07-18 21:56:05 UTC
I still have the same problem with the new selinux-policy-targeted-1.25.2-4

Comment 10 Eric Tanguy 2005-07-28 19:04:40 UTC
The problem seems to be solved with selinux-policy-targeted-1.25.3-6.


Note You need to log in before you can comment on or make changes to this bug.