Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1605149 - undercloud deployment fails, systemd-219-57.el7_5.1.x86_64 (installed) but systemd = 219-57.el7 required
Summary: undercloud deployment fails, systemd-219-57.el7_5.1.x86_64 (installed) but sy...
Keywords:
Status: CLOSED DUPLICATE of bug 1607341
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-20 09:52 UTC by Waldemar Znoinski
Modified: 2018-07-25 12:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-24 21:06:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Waldemar Znoinski 2018-07-20 09:52:08 UTC
Description of problem:
Installing undercloud fails with the below error:

2018-07-20 05:17:24,207 INFO: Notice: /Stage[main]/Ironic::Api/Package[ironic-api]/ensure: created
2018-07-20 05:17:25,862 INFO: Notice: /Stage[main]/Ironic::Conductor/Package[ironic-conductor]/ensure: created
2018-07-20 05:17:27,678 INFO: Error: Execution of '/bin/yum -d 0 -e 0 -y install systemd-python' returned 1: Error: Package: systemd-python-219-57.el7.x86_64 (rhelosp-rhel-7.5-server)
2018-07-20 05:17:27,678 INFO:            Requires: systemd = 219-57.el7
2018-07-20 05:17:27,678 INFO:            Installed: systemd-219-57.el7_5.1.x86_64 (installed)
2018-07-20 05:17:27,678 INFO:                systemd = 219-57.el7_5.1
2018-07-20 05:17:27,678 INFO:            Available: systemd-208-11.el7.x86_64 (rhelosp-rhel-7.5-server)
2018-07-20 05:17:27,678 INFO:                systemd = 208-11.el7
--
2018-07-20 05:17:27,684 INFO:  You could try using --skip-broken to work around the problem
2018-07-20 05:17:27,684 INFO:  You could try running: rpm -Va --nofiles --nodigest
2018-07-20 05:17:27,685 INFO: Error: /Stage[main]/Ironic::Drivers::Ansible/Package[systemd-python]/ensure: change from purged to present failed: Execution of '/bin/yum -d 0 -e 0 -y install systemd-python' returned 1: Error: Package: systemd-python-219-57.el7.x86_64 (rhelosp-rhel-7.5-server)
2018-07-20 05:17:27,685 INFO:            Requires: systemd = 219-57.el7
2018-07-20 05:17:27,685 INFO:            Installed: systemd-219-57.el7_5.1.x86_64 (installed)
2018-07-20 05:17:27,685 INFO:                systemd = 219-57.el7_5.1
2018-07-20 05:17:27,685 INFO:            Available: systemd-208-11.el7.x86_64 (rhelosp-rhel-7.5-server)
2018-07-20 05:17:27,685 INFO:                systemd = 208-11.el7
--
2018-07-20 05:22:09,782 INFO: Notice: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Dependency Package[systemd-python] has failures: true
2018-07-20 05:22:09,782 INFO: Warning: /Stage[main]/Keystone::Deps/Anchor[keystone::service::end]: Skipping because of failed dependencies
2018-07-20 05:25:04,159 INFO: Error: Failed to apply catalog: Execution of '/bin/openstack role list --quiet --format csv' returned 1: Unable to establish connection to http://192.168.24.1:35357/v3/roles?: HTTPConnectionPool(host='192.168.24.1', port=35357): Max retries exceeded with url: /v3/roles (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f30bf03e0d0>: Failed to establish a new connection: [Errno 111] Connection refused',)) (tried 47, for a total of 170 seconds)
2018-07-20 05:25:04,161 INFO: Changes:
2018-07-20 05:25:04,161 INFO:             Total: 933
2018-07-20 05:25:04,161 INFO: Events:
2018-07-20 05:25:04,161 INFO:           Failure: 1
2018-07-20 05:25:04,161 INFO:           Success: 933



CI JOB SHOWING THE PROBLEM: https://url.corp.redhat.com/a6c4e76


Version-Release number of selected component (if applicable):
puddle 2018-07-13.1
tried rhel-guest-image-7.5-184.x86_64.qcow2  and rhel-guest-image-7.5-146.x86_64.qcow2   

How reproducible:
100%


Steps to Reproduce:
1. create a VM from one of the above rhel 7.5 guest images
2. install undercloud
3.

Actual results:
undercloud fails to install

Expected results:
undercloud to install

Additional info:

Comment 1 Mike Burns 2018-07-24 21:06:32 UTC
This is notabug.  You're using a too-new guest image to seed your environment.  Please use the released guest image instead.  

systemd-219-57.el7 is the latest shipped version
systemd-219-57.el7_5.1 has not shipped live

Comment 2 Waldemar Znoinski 2018-07-25 12:26:34 UTC

*** This bug has been marked as a duplicate of bug 1607341 ***


Note You need to log in before you can comment on or make changes to this bug.