Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160513 - nfs client hangs when mounting/unmouting repeatedly the same disk
Summary: nfs client hangs when mounting/unmouting repeatedly the same disk
Keywords:
Status: CLOSED DUPLICATE of bug 160514
Alias: None
Product: Fedora
Classification: Fedora
Component: nfs-utils
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 15:17 UTC by Dimitri Papadopoulos
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-15 15:49:31 UTC


Attachments (Terms of Use)

Description Dimitri Papadopoulos 2005-06-15 15:17:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Mounting/unmounting the same remote directory repeatedly hangs the client:

# mount -t nfs pelles:/outils/linux/local /usr/local
# mount | fgrep pelles
pelles:/outils/linux/local on /usr/local type nfs (rw,addr=172.16.4.204)
# umount /usr/local
# 
# mount -t nfs pelles:/outils/linux/local /usr/local
# mount | fgrep pelles
pelles:/outils/linux/local on /usr/local type nfs (rw,addr=172.16.4.204)
# umount /usr/local
# 
# mount -t nfs pelles:/outils/linux/local /usr/local
[***hangs here for a few minutes***]
mount: pelles:/outils/linux/local: can't read superblock
# mount | fgrep pelles
#
# mount -t nfs pelles:/outils/linux/local /usr/local
# mount | fgrep pelles
pelles:/outils/linux/local on /usr/local type nfs (rw,addr=172.16.4.204)
# umount /usr/local
# 

The NFS server is running IRIX:
$ uname -aR
IRIX64 pelles 6.5 6.5.23f 01080747 IP27
$ 

I cannot reproduce the client hanging with a Solaris 8 NFS server:
$ uname -a
SunOS uriens 5.8 Generic_108528-22 sun4u sparc SUNW,Sun-Fire-480R
$ 

This could be a problem with IRIX, but on the other hand we have been running Red Hat 9, Fedora Core 2, and Solaris 8 client workstations without such problems for years.


Version-Release number of selected component (if applicable):
nfs-utils-1.0.7-8

How reproducible:
Sometimes

Steps to Reproduce:
1. mount -t nfs irix:/bar /mnt/foo ; umount /mnt/foo
2. repeat 1 until client hangs


Additional info:

Comment 1 Dimitri Papadopoulos 2005-06-15 15:49:31 UTC

*** This bug has been marked as a duplicate of 160514 ***


Note You need to log in before you can comment on or make changes to this bug.