Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160502 - ssh: error while loading shared libraries:
Summary: ssh: error while loading shared libraries:
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openssh
Version: 3.0
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-15 14:47 UTC by Julie Battle
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-07-04 07:48:41 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Julie Battle 2005-06-15 14:47:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Just did a fresh install of version 3, update 5.  Tried to use ssh to connect to other machines:

got this error:

ssh: error while loading shared libraries:
cannot open shared object file: No such file or directory

I modified my PATH environment variable to point to /usr/kerberos/[lib|lib64]/, but still couldn't ssh.

Had Update 5 BETA previously loaded on this exact architecture, and ssh worked fine there.

Searched RedHat Knowledgebase for "" and just got a bunch of nonsense that has nothing to do with

Help !

Julie Battle

Version-Release number of selected component (if applicable):
Version 3 Update 5

How reproducible:

Steps to Reproduce:
1. type ssh on the command line
2. watch error appear

Actual Results:  received error, then got a prompt back

Expected Results:  I should have gotten a secure-shell connection to another server.  Network connectivity exists, because telnet outbound works OK.

Additional info:

Comment 1 Tomas Mraz 2005-06-15 15:07:58 UTC
What is the contents of the /etc/ file?

Comment 2 Tomas Mraz 2005-07-01 08:26:50 UTC
And what ldd /usr/bin/ssh prints?

Comment 3 Tomas Mraz 2005-07-04 07:48:41 UTC
I've got a mail from the reporter that this bug no longer happens on her system
after reinstalling.

Note You need to log in before you can comment on or make changes to this bug.