Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160483 - Installer crashes at timezone selection screen
Summary: Installer crashes at timezone selection screen
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
: 161363 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 13:21 UTC by Jesse Edwards
Modified: 2008-08-02 23:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-15 15:09:26 UTC


Attachments (Terms of Use)

Description Jesse Edwards 2005-06-15 13:21:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Anaconda crashes after the firewall/SeLinux selection screen on an IBM T42p laptop.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run installer (graphical or command line)
2. Manual partitioning
3. Any combination of firewall/selinux options
  

Actual Results:  Installer hung for a few minutes, then generated the error listed.

Expected Results:  Timezone selection screen should have appeared.

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 876, in nextClicked
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1198, in setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/usr/lib/anaconda/iw/timezone_gui.py", line 53, in getScreen
    self.tz = TimezoneMap(zonetab=zonetab, map=path)
  File "/usr/lib/anaconda/iw/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
AttributeError: 'TimezoneMap' object has no attribute 'currentEntry'

Comment 1 Raymond Prach 2005-06-15 20:06:04 UTC
The exact same thing happens on a Thinkpad T41.

Comment 2 Chris Lumens 2005-06-15 20:38:09 UTC
Have you verified your installation media with media check?  What is your
installation language?  Can you switch over to tty2 (ctrl-alt-f2) and verify
that the file /usr/share/zoneinfo/zone.tab exists?

Comment 3 Jesse Edwards 2005-06-16 13:34:33 UTC
Media passed verification.  I'll check on the zone.tab.  

Comment 4 Rahul Sundaram 2005-06-24 11:51:08 UTC
*** Bug 161363 has been marked as a duplicate of this bug. ***

Comment 5 Mårten Lerner 2005-06-28 11:34:32 UTC
The same thing happens me on my dell Precision M 20. The media passes okey but
anaconda dies after the firewall-view. (dont know if it matter but im installing
from the DVD-iso)

Comment 6 Mykel Alvis 2005-08-23 00:45:49 UTC
Precisely the same issues happen to me.  Using the DVD iso, verified the media,
checked for the existence of /usr/share/zoneinfo/zone.tab (which exists but is
empty)

Comment 7 Mykel Alvis 2005-08-23 00:49:27 UTC
I should also note that I'm running the install DVD from an external usb2.0 DVD
drive plugged into a usb 2.0 port.

Comment 8 Mykel Alvis 2005-08-23 08:53:16 UTC
Just to make it more interesting, the exact same effect occurs when I install
from CDs on the external DVD-ROM drive.

HOWEVER, I did come up with something that may have a bearing.  When I installed
from an internal IDE device, boththe DVD and CD got past the TZ check
immediately, but as I mentioned, both failed when I was installing from an
external USB drive.   Apparently the issue was that I was taking too long
choosing the manual disk configuration.  When I didn't take long breaks where
the drive would sit idle, the effect does NOT occur.

Comment 9 James Turner 2005-10-15 17:08:34 UTC
I also noticed that if I rushed through the disk partition selection, it didn't
happen, but if I took my time, I got the error.

Comment 10 Gavin 2005-11-13 05:15:41 UTC
I'm getting the exact same problem on a Compaq Armada M700. The DVD verified OK.

Comment 11 Chris Lumens 2006-03-29 16:49:00 UTC
Are you still experiencing this problem with FC5?  I have redone the timezone
screen completely, so this could be fixed.

Comment 12 Mykel Alvis 2006-03-29 17:18:08 UTC
I will attempt to reinstall with FC5 as soon as I have an available partition on
that machine.

Comment 13 Stuart MacDonald 2006-06-05 21:20:16 UTC
I have not seen this with FC5.

The new timezone screen is missing one nicety of the old: when twiddling the
city-arrow around the old screen used to dynamically mention which city was
currently selected; the new does not.

Comment 15 Mykel Alvis 2007-01-15 08:32:40 UTC
I have upgraded that system to FC6 and I did not see that issue.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.