Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160477 - When X starts the graphics get messed up
Summary: When X starts the graphics get messed up
Keywords:
Status: CLOSED DUPLICATE of bug 161242
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 12:35 UTC by Kaare Teilum
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-29 21:19:20 UTC


Attachments (Terms of Use)

Description Kaare Teilum 2005-06-15 12:35:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When the computer boot there are no problems with the graphics. The GRUB screen appears OK and the first lines of messages during linux-startup is also OK. Just when the FC graphic boot screen appears the graphics get messed up - and the graphics stay messed up no matter what i do. I was also unable to use the graphic installation as I had the same problems.
My graphic adaptor is a Matrox Millenium G550, the processor Athlon XP 3200+, and the motherboard an Asus A7N8X.
I have run installations of both FC1 and FC2 on this machine without any problems.


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-31

How reproducible:
Always

Steps to Reproduce:
1.Boot the machine
2.
3.
  

Additional info:

Comment 1 Mike A. Harris 2005-06-21 17:02:38 UTC
Does bug #153729 adequately describe the problem?

Please attach your X server config file and log file.

Comment 2 Mike A. Harris 2005-06-21 17:41:46 UTC
Also, have a look at bug #161242 which is a new master bug I've made to
track the problem which I think might be the root cause of the issue
reported here and elsewhere in bugzilla.

Thanks in advance.

Comment 3 Mike A. Harris 2005-06-23 17:47:25 UTC
For those experiencing issues of this nature, I have uploaded the libvgahw.a
X server module from the current FC3 errata release to my ftp space:

ftp://people.redhat.com/mharris/libvgahw.a

This should make it easier for some people to test out the module hopefully,
and also have a temporary workaround.

Please provide feedback on the results of your testing ASAP.

Setting status to "NEEDINFO"

Comment 4 Kaare Teilum 2005-06-28 10:06:43 UTC
I did have an intense green border and otherwise pale green terminals in
ctrl/alt/1-6 and replaceing libvgahw with the FC3 version removed the green
stuff but the text was still unreadable. The same appearance as in the graphic
mode (ctrl/alt/7) was observed - namely that the display is divided in 1 cm
vertical sections and that some of these sections are copies of the section next
to the neighbouring section (do you get what I mean??)

Notice that the problem appeared already under graphical installation. I had to
use text installation which showed none of the problems.

As I was only able to work on the computer by ssh access from another computer I
tried to downgrade X to xorg-x11-6.8.2-1.FC3.13 which solved all problems. I did
not make a copy of the X server config and log files and don't have the time
right now to upgrade X to the FC4 version to get that done.

I think there are two issues both the green border thing and something else -
just like in bug 153729.

Comment 5 Mike A. Harris 2005-06-29 21:19:20 UTC

*** This bug has been marked as a duplicate of 161242 ***


Note You need to log in before you can comment on or make changes to this bug.