Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160476 - No Chess menu item after upgrading from FC3 to FC4
Summary: No Chess menu item after upgrading from FC3 to FC4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xboard
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Chris Ricker
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 12:33 UTC by Colin Adams
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.2.7-11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-16 16:15:03 UTC


Attachments (Terms of Use)

Description Colin Adams 2005-06-15 12:33:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
After upgrading from FC3 to FC4, attempting to run xboard reported
a problem - unable to find libreadline.so.4.
Surmising that the system upgrade had not upgraded this game, I did a yum upgrade on gnuchess and xboard.
But after that, there was no longer an entry on the GNOME Games menu for Chess.
The fix was to edit /usr/share/application/fedora-xboard.desktop to change
Categories=X-Fedora;
 to
Categories=Game;X-Fedora;
and then to run update-desktop-database

Version-Release number of selected component (if applicable):
xboard-4.2.7-10.fc4

How reproducible:
Always

Steps to Reproduce:
1.See description
2.
3.
  

Additional info:

Problem solved locally, but bug created to alert package maintainer.

Comment 1 Chris Ricker 2005-06-16 16:14:07 UTC
Thanks for the report. A new build is currently being requested which should fix
the missing Game category

BTW, you're right about the libreadline problem and solution - xboard moved from
Core to Extras, and anaconda doesn't automatically update apps from Extras. A
yum update immediately after upgrade is always a good idea because of that....


Note You need to log in before you can comment on or make changes to this bug.