Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160475 - system-config-packages not resolving dependencies and asking for same CD several times
Summary: system-config-packages not resolving dependencies and asking for same CD seve...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 130181 163426 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 12:22 UTC by Alexandre Gomes
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-21 20:02:08 UTC


Attachments (Terms of Use)

Description Alexandre Gomes 2005-06-15 12:22:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Unlike anaconda, the system-config-packages isn't handling dependencies, instead it just says they are missing and we need to find the right package for it.

There should be integration with yum and/or up2date to handle this - or FC should start to use synaptic by default :)

Second problem, system-config-packages should be caching all rpms, asking once for each needed CD then installing or something else... just not asking CD's 1-2-1-4-3 like he did when removing and installing several packages.

Version-Release number of selected component (if applicable):
system-config-packages-1.2.25-1

How reproducible:
Always

Steps to Reproduce:
1. For example - if I remember well - uninstall �Mail Server'
2. Spamassasin and other will miss it :)

Additional info:

Comment 1 Per-Ove Ottosson 2005-07-14 08:37:53 UTC
It is not handling DVD (It cannot find RPM:s on the Fedora DVD)

Comment 2 Per-Ove Ottosson 2005-07-16 14:13:11 UTC
(In reply to comment #1)
> It is not handling DVD (It cannot find RPM:s on the Fedora DVD)

Sorry this bug is already reported as 130181



Comment 3 Máirín Duffy 2005-07-28 14:06:26 UTC
*** Bug 130181 has been marked as a duplicate of this bug. ***

Comment 4 Máirín Duffy 2005-07-28 14:08:42 UTC
*** Bug 163426 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2005-09-21 20:02:08 UTC
This will be fixed in FC5


Note You need to log in before you can comment on or make changes to this bug.