Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160469 - Unable to handle '.' in usernames (name.lastname)
Summary: Unable to handle '.' in usernames (name.lastname)
Keywords:
Status: CLOSED DUPLICATE of bug 159034
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: shadow-utils
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 10:54 UTC by Milan Kerslager
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-01 04:41:21 UTC


Attachments (Terms of Use)
Extended goodname patch to allow dots in usernames (deleted)
2005-06-15 10:54 UTC, Milan Kerslager
no flags Details | Diff

Description Milan Kerslager 2005-06-15 10:54:01 UTC
After last update (4.0.3-22.02 -> 4.0.3-23.08) this is impossible to use dot
(".") in the username (john.rambo). This breaks backward compatibility and makes
troubles for sites where the policy for login names allow dots since RHEL2. See
the bug #89205 for references (this a second same issue for RHEL3, see the bug
#108614 - this has been resolved in the previous updates for RHEL3).

The problem is in shadow-4.0.3-goodname.patch where new patch replaced old patch
completly. I'm attaching fixed patch and my personal rebuild for RHEL3 can be
found at:

ftp://ftp.pslib.cz/pub/users/Milan.Kerslager/RHEL-3/stable/
ftp://ftp.linux.cz/pub/linux/people/milan_kerslager/RHEL-3/stable/

Comment 1 Milan Kerslager 2005-06-15 10:54:01 UTC
Created attachment 115470 [details]
Extended goodname patch to allow dots in usernames

Comment 2 Milan Kerslager 2005-06-15 11:09:06 UTC
This seems to be better to use patch from shadow-utils-4.0.3-41.1.src.rpm (RHEL4
package) where the rest of the original goodname patch has been restored too).
My build uses it.

Comment 3 Mike Frysinger 2005-07-01 03:33:47 UTC
Bug 159034 has already been filed about this issue ...

Comment 4 Milan Kerslager 2005-07-01 04:41:21 UTC

*** This bug has been marked as a duplicate of 159034 ***


Note You need to log in before you can comment on or make changes to this bug.