Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160463 - postgresql installed by FC4 needs a different data format than FC3
Summary: postgresql installed by FC4 needs a different data format than FC3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tom Lane
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 10:11 UTC by Flavio Cardone
Modified: 2013-07-03 03:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-15 14:03:26 UTC


Attachments (Terms of Use)

Description Flavio Cardone 2005-06-15 10:11:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
FC3 had postgresql 7.4 but FC4 has 8.0.3. The latter will not start and reports that the data format needs to be updated. However, to update the data according to the instructions by postgresql.org you need to have a running postgresql server. Catch 22.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. have postgresql in FC3
2. install FC4
3. try starting postgresql
  

Additional info:

Comment 1 Tom Lane 2005-06-15 14:03:26 UTC
You have to dump and restore the old database.  This has always been true of
every major Postgres version upgrade, and 7.4 -> 8.0 is no different.

Comment 2 Flavio Cardone 2005-06-16 08:48:34 UTC
Yes, of course, but if you install FC4 (postgres 8.0) over FC3 (postgres 7.4),
you only realize you had to dump your database after you already installed FC4.
And once you installed FC4, you can't dump your database because postgres 8.0
won't start...


Note You need to log in before you can comment on or make changes to this bug.