Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160455 - _SERIOUS_ problem in eclipse
Summary: _SERIOUS_ problem in eclipse
Keywords:
Status: CLOSED DUPLICATE of bug 152386
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 09:38 UTC by Andrea Santilli
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-15 12:41:34 UTC


Attachments (Terms of Use)

Description Andrea Santilli 2005-06-15 09:38:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Running Eclipse as root completely hangs the system (1 x Pentium4 HT 2600MHz, maybe it's because of the smp).
When I run it again (as root, after forced reboot) I get an error message saying to see details in a log file. On that log file there's written as follows:

!SESSION 2005-06-15 10:21:08.681 -----------------------------------------------
eclipse.buildId=unknown
java.fullversion=GNU libgcj 4.0.0 20050519 (Red Hat 4.0.0-8)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=it_IT
Command-line arguments:  -os linux -ws gtk -arch x86 -data /root/workspace -clean

!ENTRY org.eclipse.osgi 2005-06-15 10:21:08.682
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
   at org.eclipse.core.internal.runtime.PlatformActivator$1.run(java.lang.Object) (/usr/lib/eclipse/plugins/org.eclipse.core.runtime_3.1.0.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(java.lang.Object) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(java.lang.String[], java.lang.Runnable) (/usr/lib/eclipse/plugins/org.eclipse.osgi_3.1.0.jar.so)
   at java.lang.reflect.Method.invoke(java.lang.Object, java.lang.Object[]) (/usr/lib/libgcj.so.6.0.0)
   at org.eclipse.core.launcher.Main.invokeFramework(java.lang.String[], java.net.URL[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.basicRun(java.lang.String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.run(java.lang.String[]) (Unknown Source)
   at org.eclipse.core.launcher.Main.main(java.lang.String[]) (Unknown Source)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)

If I can't run it as root, it's supposed I must install a copy of new plugins for every user...

Running it as normal user (after doing all I've written before) I get the same error.

I had to uninstall eclipse and all its depedancies, erase /usr/share/eclipse dir and install it again. Now it runs good (only as normal user).

Version-Release number of selected component (if applicable):
3.1.0_fc-0.M6.22

How reproducible:
Always

Steps to Reproduce:
1. Run eclipse as root. The system completely hangs.
2. Restart eclipse after forced reboot
3. I get that error
  

Actual Results:  System hang, wrong configuration.

Expected Results:  Eclipse run perfectly

Additional info:

Running on a SMP kernel (1 x Pentium 4 HyperThreading 2600MHz)

Comment 1 stef 2005-06-15 09:52:52 UTC
I confirm, crashes the whole system if run as root.
System is a PIII 1GHz mono-cpu with 256Mo RAM and SCSI160 disk, so seems not SMP
related.

Comment 2 Andrew Overholt 2005-06-15 12:41:34 UTC

*** This bug has been marked as a duplicate of 152386 ***


Note You need to log in before you can comment on or make changes to this bug.