Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160451 - Evolution crashes on view change or preference update
Summary: Evolution crashes on view change or preference update
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 09:01 UTC by Thomas Fischer
Modified: 2018-04-11 13:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-02 18:41:34 UTC


Attachments (Terms of Use)
Backtrace results from gdb (deleted)
2005-06-15 09:03 UTC, Thomas Fischer
no flags Details
Backtrace results from bug buddy (deleted)
2005-06-15 09:04 UTC, Thomas Fischer
no flags Details

Description Thomas Fischer 2005-06-15 09:01:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
When evolution is running, if I select the Settings menu and then close the settings dialog evolution crashes with a segmentation fault.
The same happens after having changed a calendar or addressbook view and then reopening Evolution. 

I ran a gdb with the debug packages installed. See attachment

Version-Release number of selected component (if applicable):
evolution-2.0.4-4, libgal2-2.2.5-1

How reproducible:
Always

Steps to Reproduce:
1. Launch evolution
2. Select settings from Tools menu
3. Change a setting in any tab
4. click on Close button of settings dialog
5. Evolution crashes
  

Actual Results:  Evolution crashes with segementation fault

Expected Results:  window should close and evolution should continue to run as normal

Additional info:

This bug only started to appear around May 27th 2005. Before evolution was working normally. I have been regularly updating FC3 components with yum.

I have tried with a new gconfd tree for evolution and a new data store and the problem still occurs.

Comment 1 Thomas Fischer 2005-06-15 09:03:31 UTC
Created attachment 115464 [details]
Backtrace results from gdb

Comment 2 Thomas Fischer 2005-06-15 09:04:02 UTC
Created attachment 115465 [details]
Backtrace results from bug buddy

Comment 3 Thomas Fischer 2005-06-27 08:12:56 UTC
Found this bug in Gnome BugZilla that looks exactly like the problem I am having:
http://bugzilla.gnome.org/show_bug.cgi?id=304915

Comment 4 Matthew Miller 2006-07-10 21:50:13 UTC
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!


Comment 5 Matěj Cepl 2007-08-31 15:20:13 UTC
The distribution against which this bug was reported is no longer supported,
could you please reproduce this with the updated version of the currently
supported distribution (Fedora Core 6, or Fedora 7, or Rawhide)? If this issue
turns out to still be reproducible, please let us know in this bug report.  If
after a month's time we have not heard back from you, we will have to close this
bug as INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.

Comment 6 Matthew Barnes 2007-10-02 18:41:34 UTC
Closing as INSUFFICIENT_DATA.


Note You need to log in before you can comment on or make changes to this bug.