Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160446 - up2date Python traceback when scheduled package removal
Summary: up2date Python traceback when scheduled package removal
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 08:24 UTC by Martin Wyser
Modified: 2018-10-19 20:54 UTC (History)
3 users (show)

Fixed In Version: 4.4.50
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-04 17:40:59 UTC


Attachments (Terms of Use)

Description Martin Wyser 2005-06-15 08:24:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031114

Description of problem:
In the RHN, I schedule a package removal, which later fails with this:
=================
Package Removal scheduled by dinfk-iks
Details:     This action will be executed after 2005-06-14 09:59:00 CEST.

This action's status is: Failed.
The client picked up this action on 2005-06-14 10:00:35 CEST.
The client completed this action on 2005-06-14 10:00:36 CEST.
Client execution returned "Fatal error in Python code occured [[6]]"
(code -1)
Packages to be removed:

    * mikmod-3.1.6-30.1
=================
I schedule it again, and run rhn_check -v on the machine to see more, instead of waiting for rhnsd.  Now I get:
=================
[root@ikq1 ~]# rhn_check -v
packages.remove ([['mikmod', '3.1.6', '30.1', '']],)
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 174, in run_action
    (status, message, data) = do_call(method, params)
  File "/usr/sbin/rhn_check", line 91, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 83, in remove
    up2date.removePackages(pkgList, rpmCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1009, in
removePackages
    runTransaction(ts,rpmCallback)
TypeError: runTransaction() takes at least 4 arguments (2 given)
=================

In fact, at line 1009 of /usr/share/rhn/up2date_client/up2date.py, there is a bad call to rpmTransaction which is defined in the same file at line 602.

Version-Release number of selected component (if applicable):
up2date-4.4.5.6-2

How reproducible:
Always

Steps to Reproduce:
1. Schedule a package removal on the RHN server for a system
2. run rhn_check -v on the system
3. or wait until rhnsd checks in
  

Actual Results:  Traceback, package not removed, action fails in RHN

Expected Results:  package removed

Additional info:

Comment 2 Niels Happel 2005-08-22 14:34:27 UTC
This works for me to get it running:

1009c1009
<     runTransaction(ts, [], [], rpmCallback)
---
>     runTransaction(ts,rpmCallback)



Comment 3 Adrian Likins 2005-10-04 17:40:59 UTC
This is fixed in current up2date releases (rhel3u6/rhel4u2).

Comment 4 Debbie McGrath 2005-10-04 17:45:49 UTC
Removing from RHEL 4 U3 lists.



Note You need to log in before you can comment on or make changes to this bug.