Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160444 - mkrootdev: label / not found with / in xfs - Kernel panic
Summary: mkrootdev: label / not found with / in xfs - Kernel panic
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: grub
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 07:49 UTC by Laurent Blin
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 22:21:53 UTC


Attachments (Terms of Use)

Description Laurent Blin 2005-06-15 07:49:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.8) Gecko/20050512 Firefox/1.0.4

Description of problem:
Here is the partition table used:
- 100M - /boot - ext3
- 10G - / - XFS
- 5G - VFAT (for win)
- Extended
- 5G - VFAT (for win)
- 1G - swat - swat
- 1G - /var - XFS
- 15G - /home - XFS

The installation goes without any problem. When the system reboot, the message appears, just after grub loader

mkrootdev: label / not found
with some xfs error message.
In rescue mode (linux xfs rescue), Fedora can't mount automatically / on /mnt/sysimage.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install Fedora Core 4 from DVD x86 with xfs support (linus xfs)
2. format the disk as above (with grub on /dev/hda)
3. at the end of the install, the system reboots, than hags with kernel panic
  

Expected Results:  The system should have started.

Additional info:

Comment 1 Laurent Blin 2005-06-15 14:13:16 UTC
Here are the complete messages:
root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=LQBEL=/ rhgb quiet
  [Linux-bzImage, setup=0x1e00, size=0x18e473]
initrd /initrd-2.6.11-1.1369_FC4.img
  [Linux-initrd @ 0xfe22000,0x13ddde bytes]

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version 4.2.15 starting
mkrootdev: label / not found
mount: error 2 mounting xfs
ERROR opeing /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init!

Comment 2 Laurent Blin 2005-06-15 15:22:56 UTC
No pb when I use an EXT3 formatted / partition, and keep a XFS /home.
Is there a pb loading a / in XFS?

Comment 3 Furry Ball 2005-06-17 13:38:36 UTC
I can confirm this bug report. Just did "linux xfs" install with manually
created partitions. Had to use Kubuntu livecd (the only one handy) to xfs_admin
-L / /dev/sda3 (my root partition) to fix it. The installer doesn't label the
XFS root partition for some reason at all.

Comment 4 Gerald Britton 2005-06-18 22:10:34 UTC
I ran into this issue and the fix initially worked, but I ended up with grub
losing one of its stages and booting to just "GRUB " so I booted in rescue mode
prepared to do a grub-install to fix it, but that would segfault within grub.
After installing grub-debuginfo, I found that it was in xfs traversal code that
grub was segfaulting.  My guess is that grub-install won't work properly on a
mounted xfs filesystem (and since grub requires writing to the filesystem, this
may not be easily solvable).

I reinstalled with an ext3 /boot, and went over to a shell at the end of the
installation process to relabel the / filesystem, and looked at what it was
labeled initially and found that it had been labeled properly with "/" as the
filesystem label, however, the filesystem was inconsistant with the duplicate
superblocks (or xfs's equivalent) not agreeing.  I suspect anaconda may have
labeled the filesystem while it was mounted (which xfs does not seem to safely
support).

This bug probably ought to be an anaconda bug.

Comment 5 Orion Poplawski 2005-06-21 17:31:42 UTC
Looks like the initial label created during install is bad somehow:

[root@coop01 ~]# mount -a
mount: special device LABEL=/scratch does not exist
[root@coop01 ~]# xfs_admin -l -f /dev/hda7
warning: AG 1 label differs
warning: AG 2 label differs
warning: AG 3 label differs
warning: AG 4 label differs
warning: AG 5 label differs
warning: AG 6 label differs
warning: AG 7 label differs
warning: AG 8 label differs
warning: AG 9 label differs
warning: AG 10 label differs
warning: AG 11 label differs
warning: AG 12 label differs
warning: AG 13 label differs
warning: AG 14 label differs
warning: AG 15 label differs
label = "/scratch"
[root@coop01 ~]# xfs_admin -L /scratch -f /dev/hda7
writing all SBs
new label = "/scratch"
[root@coop01 ~]# xfs_admin -l -f /dev/hda7
label = "/scratch"
[root@coop01 ~]# mount /scratch
[root@coop01 ~]#                 

Comment 6 Joseph Teichman 2005-06-23 00:47:23 UTC
Check if this relates to the bug that I had here with a deficient initial root
disk image, Bug # 161406

Comment 7 Peter Jones 2005-07-06 22:21:53 UTC
xfs is completely unsupported.


Note You need to log in before you can comment on or make changes to this bug.