Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160438 - No sound produced for Audigy 2 ZS
Summary: No sound produced for Audigy 2 ZS
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 06:45 UTC by Mark Adams
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-11 14:09:13 UTC


Attachments (Terms of Use)
amixer output when sound not working (deleted)
2005-06-22 11:08 UTC, Rosen Nedialkov
no flags Details
and with sound working (deleted)
2005-06-22 11:09 UTC, Rosen Nedialkov
no flags Details

Description Mark Adams 2005-06-15 06:45:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
system-config-soundcard identifies my Audigy 2 ZS as a Labs SB Audigy using module snd-emu10k1. However, no sound is produced when playing the test sound. When run from the command line, the following messages are produced:
---------------------------------------------
amixer: Unknown playback setup 'on'..

amixer: Unknown playback setup 'on'..

amixer: Unable to find simple control 'PCM-2',0

amixer: Unable to find simple control 'DRC Range',0

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
---------------------------------------------
Playing music doesn't work, and neither does trying to play a .wav file via aplay. I've checked the gnome volume control and made sure everything was enabled, to no effect.

In case it helps, here's the output from 'aplay -l':
----------------------------------------------
**** List of PLAYBACK Hardware Devices ****
card 0: SB0350 [Audigy 2 ZS [SB0350]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 32/32
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
  Subdevice #8: subdevice #8
  Subdevice #9: subdevice #9
  Subdevice #10: subdevice #10
  Subdevice #11: subdevice #11
  Subdevice #12: subdevice #12
  Subdevice #13: subdevice #13
  Subdevice #14: subdevice #14
  Subdevice #15: subdevice #15
  Subdevice #16: subdevice #16
  Subdevice #17: subdevice #17
  Subdevice #18: subdevice #18
  Subdevice #19: subdevice #19
  Subdevice #20: subdevice #20
  Subdevice #21: subdevice #21
  Subdevice #22: subdevice #22
  Subdevice #23: subdevice #23
  Subdevice #24: subdevice #24
  Subdevice #25: subdevice #25
  Subdevice #26: subdevice #26
  Subdevice #27: subdevice #27
  Subdevice #28: subdevice #28
  Subdevice #29: subdevice #29
  Subdevice #30: subdevice #30
  Subdevice #31: subdevice #31
card 0: SB0350 [Audigy 2 ZS [SB0350]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: SB0350 [Audigy 2 ZS [SB0350]], device 3: emu10k1 [Multichannel Playback]  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB0350 [Audigy 2 ZS [SB0350]], device 4: p16v [p16v]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
-----------------------------------------
I'm happy to provide any requested info and/or try patches.


Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.11-5

How reproducible:
Always

Steps to Reproduce:
1. Try to play a sound.
2.
3.
  

Actual Results:  Nothing.


Expected Results:  Sound heard.


Additional info:

Comment 1 J.Scott 2005-06-15 15:48:21 UTC
I would also like to confim this is happening on my system aswell with a clean
FC4 install. The same settings as above, AXP 2100+ on an A7N8X DLX (onboard
audio is turned off). Thanks.

Comment 2 Fred Romelfanger 2005-06-16 00:30:35 UTC
Same problem on my system with an Audigy 2 running under fc4 with the same
device as listed above. clean fc4 install on a dell 8400.

Comment 3 Rosen Nedialkov 2005-06-16 17:59:04 UTC
The same problem here. Clean FC4 install with Audigy 2 ZS. AXP 1700+ on GB
GA-7VTXE+. The onboard sound is turned off.

Comment 4 Rosen Nedialkov 2005-06-16 22:23:10 UTC
Here you can find a workaround

http://forums.fedoraforum.org/showthread.php?p=280406#post280406

In short:
1. open gnome mixer, Edit->Preferences
2. Select Audigy Analog/Digital Output Jack, IEC958 Optical Raw and Tone
3. Check that Tone and IEC958 is disabled, and enable Audigy Analog/Digital
Output Jack

Comment 5 Martin Stransky 2005-06-22 06:33:31 UTC
Which driver do you use?
Works this workaround for you?

Comment 6 Rosen Nedialkov 2005-06-22 10:09:00 UTC
(In reply to comment #5)
> Which driver do you use?
> Works this workaround for you?

The module is snd-emu10k1 as system-config-soundcard finds it. But I think that
the problem is with the default settings which are set for the volume control
(alsamixer).

And yes for me it works.

Comment 7 Martin Stransky 2005-06-22 10:27:32 UTC
Can you please attach output of amixer when sound doesn't work?


Comment 8 Rosen Nedialkov 2005-06-22 11:08:56 UTC
Created attachment 115804 [details]
amixer output when sound not working

Comment 9 Rosen Nedialkov 2005-06-22 11:09:48 UTC
Created attachment 115805 [details]
and with sound working

Comment 10 Rosen Nedialkov 2005-06-22 11:12:18 UTC
Here is the diff.

[lordross@aurora ~]$ diff amixer-sound.txt amixer-nosound.txt
0a1
> [lordross@aurora ~]$ amixer
180c181
<   Mono: Playback [on]
---
>   Mono: Playback [off]

Curiously for me now when cheking and unchecking only the "Audigy Analog/Digital
Output Jack" option the sound stops and starts.

Comment 11 woot 2005-06-25 05:07:42 UTC
I am also having this problem... I tried the workaround and it is not working

Also to note:

I am using the audigy front panel optical out to my amplifier.. I have run slax
Live linux and sound output works perfectly there...

... also when I boot up using Fedora Core 4, sometimes (primarily when I boot
linux after I've booted windows) It will get to the initializing hardware ...
sound step and lock up forcing me to hard reset the computer .. upon hard reset
it usually works (is able to pass that step in booting)

Comment 12 woot 2005-06-25 05:28:08 UTC
was fudging with the gnome-volume-control and got it working

however the test sound is extremely low volume

Comment 13 Martin Stransky 2005-06-29 11:55:56 UTC
(In reply to comment #11)
> I am also having this problem... I tried the workaround and it is not working
> 
> Also to note:
> 
> I am using the audigy front panel optical out to my amplifier..

This may help you:

https://bugzilla.redhat.com/bugzilla-old/show_bug.cgi?id=160730

... adding options to /etc/modprobe.conf


Comment 14 Gantry York 2005-07-05 04:03:33 UTC
I'm having a simular problem.

I have a SoundBlaster Audigy 2.  After upgrading from FC3 to FC4, I have sound,
but the mic does not work.

Sorry, didn't mean to turn this bug into a disussion thread, but it was a
simular problem and didn't see the need to open a new bug.

By the way, I don't understand the work around.  I don't see gnome-mixer as a
binary on my system.  (nor do I see gnome-sound-recorder anymore neither).

Comment 15 Martin Stransky 2005-07-06 06:37:14 UTC
(In reply to comment #14)
> I have a SoundBlaster Audigy 2.  After upgrading from FC3 to FC4, I have sound,
> but the mic does not work.

You can use "alsamixer -V capture" to adjust/set recording channel.


Note You need to log in before you can comment on or make changes to this bug.