Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160435 - Missing Apache runtime libraries libapr-0.so.0 & libaprutil-0.so.0
Summary: Missing Apache runtime libraries libapr-0.so.0 & libaprutil-0.so.0
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 05:22 UTC by Jim Bradbury
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-15 05:54:49 UTC


Attachments (Terms of Use)

Description Jim Bradbury 2005-06-15 05:22:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.7.8-2

Description of problem:
httpd rpm from Fedora core 4 release fails to install - missing Apache runtime libraries.
log: # rpm -Uvh httpd*
warning: httpd-2.0.54-10.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        libapr-0.so.0 is needed by httpd-2.0.54-10.i386
        libaprutil-0.so.0 is needed by httpd-2.0.54-10.i386


Version-Release number of selected component (if applicable):
httpd-2.0.54-10.i386

How reproducible:
Always

Steps to Reproduce:
1. Attempt to install httpd rpm from fc4 CD-1
2.
3.
  

Actual Results:  error: Failed dependencies:
        libapr-0.so.0 is needed by httpd-2.0.54-10.i386
        libaprutil-0.so.0 is needed by httpd-2.0.54-10.i386

Expected Results:  Completed install of httpd

Additional info:

libapr-0.so.0 and ibaprutil-0.so.0 are Apache portable runtime libraries.

Comment 1 Joe Orton 2005-06-15 05:54:49 UTC
You also need to install the apr and apr-util packages.  Use "yum install httpd".


Note You need to log in before you can comment on or make changes to this bug.