Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160432 - openoffice.org doesn't use GTK2 system file chooser
Summary: openoffice.org doesn't use GTK2 system file chooser
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 04:07 UTC by Alex Lancaster
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-15 09:29:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 42429 None None None Never

Description Alex Lancaster 2005-06-15 04:07:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
Openoffice.org does not use the GTK2 File Chooser dialog when running GNOME, but always uses the OpenOffice.org dialog.  Going to Tools->Options->OpenOffice.org->General and toggling the "Use OpenOffice.org dialogs" on and then off again does not seem to work.  

I then removed and reinstalled the openoffice.org-writer and removed all .openoffice.orgxxx and .rhopenofficexxx configuration files and tried again, but it had no effect.  I know this works on other systems, but it is not clear what OOo uses to choose between the two dialogs.

Version-Release number of selected component (if applicable):
openoffice.org-1.9.104-2

How reproducible:
Always

Steps to Reproduce:
1. Install OOo
2. Start OpenOffice.org Writer from the menu.
3. Go to "Tools->Options->OpenOffice.org->General" and verify that "Use OpenOffice.org dialogs" is NOT checked.
3. Try to open a file using "Open" from the "File" menu.
  

Actual Results:  The OpenOffice.org "Open" dialog is displayed rather than the GTKFileChooser.

Expected Results:  The GTKFileChooser "Open" dialog should have been shown instead.

Additional info:

Verified that this also occurs with the "Save" dialog.

Comment 1 Caolan McNamara 2005-06-15 07:51:35 UTC
Do you have accessibility enabled ? i.e. gconf key
desktop->gnome->interface->accessibility set to true ? The gtk dialog cannot be
used under those circumstances.

Comment 2 Alex Lancaster 2005-06-15 08:36:38 UTC
Indeed that was the problem, I disabled accessibility and the GTK dialog for OOo
 returned.  Thanks!   It seems somewhat counterintuitive that accessibility
would *disable* GTK in OOo because you would think that accessibility would make
the interface more consistent across applications, not less.   It seems to me
that this behaviour is itself a bug, since it doesn't affect other GNOME
applications and therefore goes against the principle of least surprise.  Is
there an existing BZ ticket on this issue, or should I open a new one, or is it
an upstream issue?

Also, I must have had this enabled in FC3 before I upgraded and having it
enabled did not affect the type of dialog for 1.1.3 OOo (i.e. I always got the
GTK version).  I'm guessing with OOo 2.0 that part works quite differently. 

Lastly, this should be a FAQ or somehow promimently documented for OOo users on
FC4, where is the most canonical location for FAQs like these, i.e. bugs/issues
that aren't blockers but are somewhat subtle and annoying?

Comment 3 Alex Lancaster 2005-06-15 08:52:21 UTC
Whoops, I accidently closed the bug, reopening for the moment until concerns
above are addressed.

Comment 4 Caolan McNamara 2005-06-15 09:29:59 UTC
http://qa.openoffice.org/issues/show_bug.cgi?id=42429 the accessibility bridges
in 2.0 don't play fair together


Note You need to log in before you can comment on or make changes to this bug.