Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160431 - "yum remove" can not clear /etc/dhclient-exit-hooks script
Summary: "yum remove" can not clear /etc/dhclient-exit-hooks script
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firestarter
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael A. Peters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 03:29 UTC by Yusuf Ma
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-30 22:33:40 UTC


Attachments (Terms of Use)

Description Yusuf Ma 2005-06-15 03:29:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The message "... /etc/firestarter/firestarter.sh was not found" is displayed during determining the IP address from DHCP server when the system is booting up after the firestarter package was removed. I did not use graphical boot. I believe this message will not display in graphical boot.

This problem was traced to the fact that /etc/dhclient-exit-hooks file was not cleared after the package was removed. After removing "firestarter" line from this file, the problem is solved.

Version-Release number of selected component (if applicable):
firestarter-1.0.3-3

How reproducible:
Always

Steps to Reproduce:
1. Install Firestarter package. Run firestarter and configure it.
2. Remove Firestarter package.
3. Restart the system.
  

Actual Results:  firestarter.sh not found message was displayed during booting process when DHCP is determining the IP address.

Expected Results:  status "OK" without any error message

Additional info:

Comment 1 Michael A. Peters 2006-01-30 22:33:40 UTC
It should be fixed now in rawhide - a new release for fc4 will be pushed soon.


Note You need to log in before you can comment on or make changes to this bug.