Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160429 - pbmtolj segfaults
Summary: pbmtolj segfaults
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: netpbm
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-15 02:23 UTC by Jonathan Kamens
Modified: 2013-07-02 23:07 UTC (History)
1 user (show)

Fixed In Version: 10.28-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-21 14:41:29 UTC


Attachments (Terms of Use)
pbm file which croaks pbmtolj (deleted)
2005-06-15 02:23 UTC, Jonathan Kamens
no flags Details

Description Jonathan Kamens 2005-06-15 02:23:57 UTC
With netpbm-10.28-1, the attached pbm file, which is the smallest test case I
could find of this problem, causes "pbmtolj < bad.pbm > /dev/null" to coredump.
 This file does not cause pbmtolj to coredump in netpbm-10.27-4.

Comment 1 Jonathan Kamens 2005-06-15 02:23:58 UTC
Created attachment 115450 [details]
pbm file which croaks pbmtolj

Comment 2 Jindrich Novy 2005-06-21 14:41:29 UTC
This was caused by definition of NDEBUG, so assertions within the pbmtolj.c were
ignored what causes the segfault.


Note You need to log in before you can comment on or make changes to this bug.