Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160412 - [x86_64]openoffice.org segfaults during startup
Summary: [x86_64]openoffice.org segfaults during startup
Keywords:
Status: CLOSED DUPLICATE of bug 160290
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 22:15 UTC by Samuli Järvinen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-15 07:45:12 UTC


Attachments (Terms of Use)

Description Samuli Järvinen 2005-06-14 22:15:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Openoffice segfaults during startup on fresh FC4 install. Arch is x86_64.

Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.104-2

How reproducible:
Always

Steps to Reproduce:
1. Fresh install of FC4
2. Start openoffice via panel or in a terminal (Doesn't matter which component)
3. Segmentation fault.
  

Actual Results:  /usr/lib/openoffice.org1.9.104/program/soffice: line 247:  2325 Segmentation fault      "$sd_prog/$sd_binary" "$@"


Expected Results:  Openoffice should have started. (selected component)

Additional info:

Comment 1 Caolan McNamara 2005-06-14 22:59:45 UTC
please do...
gdb /usr/lib/openoffice.org1.9.104/program/soffice.bin
(gdb) run
(gdb) bt
and put the output here.

I bet you have a nvidia driver.

Comment 2 Mark Adams 2005-06-15 06:55:43 UTC
I've encountered the same bug, and your bet is correct for me. If I disable the
Nvidia driver, then OpenOffice will start.

Here's the backtrace you requested:
----------------------------------
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x006e3955 in pthread_once () from /lib/libpthread.so.0
#2  0xf75fa95e in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#3  0xf762c2b8 in ?? () from /usr/lib/libGL.so.1
#4  0xf75facb0 in _init () from /usr/lib/libGL.so.1
#5  0xffff9f10 in ?? ()
#6  0x00000000 in ?? ()
-----------------------------------
Any workarounds possible, or am I stuck choosing between 3D support or a word
processor at this point?


Comment 3 Caolan McNamara 2005-06-15 07:45:12 UTC
SAL_NOOPENGLyou can try and disable OOO's 3d support with 
export SAL_NOOPENGL=true


*** This bug has been marked as a duplicate of 160290 ***


Note You need to log in before you can comment on or make changes to this bug.