Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1604054 - gazebo: FTBFS in Fedora rawhide
Summary: gazebo: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gazebo
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Till Hofmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1605475 1606875
Blocks: F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-19 20:50 UTC by Mohan Boddu
Modified: 2018-12-01 20:40 UTC (History)
3 users (show)

Fixed In Version: gazebo-8.3.0-3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-01 20:40:37 UTC


Attachments (Terms of Use)
build.log (deleted)
2018-07-19 20:50 UTC, Mohan Boddu
no flags Details
root.log (deleted)
2018-07-19 20:51 UTC, Mohan Boddu
no flags Details
state.log (deleted)
2018-07-19 20:51 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-19 20:50:47 UTC
gazebo failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28178273


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix gazebo at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
gazebo will be orphaned. Before branching of Fedora 30,
gazebo will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-19 20:50:58 UTC
Created attachment 1462111 [details]
build.log

Comment 2 Mohan Boddu 2018-07-19 20:51:02 UTC
Created attachment 1462112 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-19 20:51:05 UTC
Created attachment 1462113 [details]
state.log

Comment 4 Jan Kurik 2018-08-14 09:40:26 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 5 Till Hofmann 2018-08-15 14:33:48 UTC
I think the problem is that python2-pyopengl does not provide PyOpenGL anymore.

Comment 6 Fedora Update System 2018-11-22 23:18:51 UTC
gazebo-8.3.0-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b59614b1a7

Comment 7 Fedora Update System 2018-11-23 02:57:10 UTC
gazebo-8.3.0-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b59614b1a7

Comment 8 Fedora Update System 2018-12-01 20:40:37 UTC
gazebo-8.3.0-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.