Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160402 - Hardware Probe Does Not Find MS optical IntelliMouse
Summary: Hardware Probe Does Not Find MS optical IntelliMouse
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 21:39 UTC by Jim Bradbury
Modified: 2014-03-17 02:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-16 20:00:15 UTC


Attachments (Terms of Use)

Description Jim Bradbury 2005-06-14 21:39:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
During Install of fc4, hardware probe could not find Microsoft optical IntelliMouse.
Mouse was optical USB mouse with PS/2 adapter plugged into PS/2 mouse port.
Replacing mouse with older Microsoft 3-button ball-type mouse plugged
into same port was found during the install and identified as generic
3-button mouse.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Tried install 3 times with Optical IntelliMouse with same result - mouse not found.
2. Switching mouse to 3-button microsoft PS/2 mouse worked. 
3.
  

Actual Results:  Mouse not found using optical USB Microsoft IntelliMouse with PS/2 adapter.
This same mouse was working fine just before the fc4 install using fc3.

Expected Results:  Anaconda hardware probe should have found the optical MS IntelliMouse.

Additional info:

Text on bottom of Mouse - "Wheel Mouse Optical USB and PS/2 Compatible"
Microsoft part No.: X05-87477

Comment 1 Bill Nottingham 2005-06-16 18:03:04 UTC
What does /proc/bus/input/devices look like with the mouse that it didn't find?

Comment 2 Jim Bradbury 2005-06-16 20:00:15 UTC
I swapped hard drives so as not to mess up my install.  I swapped the mouse back
to the offending mouse. On three successive install attempts, the mouse that
wasn't recognized the other day was recognized all three times. Close Bug.


Note You need to log in before you can comment on or make changes to this bug.