Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160397 - no sound with snd_atiixp or pcspkr on Toshiba A65-S1068
Summary: no sound with snd_atiixp or pcspkr on Toshiba A65-S1068
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-14 21:22 UTC by Roger J. Allen
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-07-05 20:46:44 UTC

Attachments (Terms of Use)
lspci from fc4 (deleted)
2005-06-14 21:29 UTC, Roger J. Allen
no flags Details
lspci -vv for fc3 (deleted)
2005-06-14 21:49 UTC, Roger J. Allen
no flags Details
dmesg from fc3 with working snd_atiixp and pcspkr (deleted)
2005-06-14 22:02 UTC, Roger J. Allen
no flags Details
dmesg from fc4 with no sound (deleted)
2005-06-14 22:15 UTC, Roger J. Allen
no flags Details

Description Roger J. Allen 2005-06-14 21:22:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
No sound from snd_atiixp or pcspkr modules.  The modules load Ok.

Sound works fine with FC3.  FC4 installed into a separate empty partition.  FC3 partition still usable for testing.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.install FC4 on Toshiba A65-S1068
2.insert Grateful Dead CD

Actual Results:  No sound until reboot to FC3

Expected Results:  Playing in the Band

Additional info:

FC3 with 2.6.11-1.27_FC3smp and adding snd_atiixp_modem to /etc/hotplug/blacklist works fine.  FC3 alsamixer v1.0.6 and FC4 alsamixer v1.0.9rc2 displays ATI IXP Realtek ALC250 rev2.  Unmuted Master, Headphones, PCM, Line, CD, PC Speak.  With FC3, can run CD Player 2.8.0 with Grateful Dead CD, ogg123 from Vorbis-tools 1.0.1 with ogg or xmms 1.2.10 with mp3 with sound working.

With FC4, after installation and bootup, snd_atiixp_modem is loaded.  After blacklisting it and rebooting, snd_atiixp_modem was still loaded.  After renaming snd_atiixp_modem.ko and rebooting, sound still doesn't work.

after modprobing pcspkr, no sounds from echo -e \\a or beeps from vi.

Comment 1 Roger J. Allen 2005-06-14 21:29:59 UTC
Created attachment 115432 [details]
lspci from fc4

Comment 2 Roger J. Allen 2005-06-14 21:49:03 UTC
Created attachment 115436 [details]
lspci -vv for fc3

Comment 3 Roger J. Allen 2005-06-14 22:02:27 UTC
Created attachment 115438 [details]
dmesg from fc3 with working snd_atiixp and pcspkr

Comment 4 Roger J. Allen 2005-06-14 22:15:20 UTC
Created attachment 115442 [details]
dmesg from fc4 with no sound

Comment 5 Victor Bogado 2005-06-16 00:24:50 UTC
I had a similar problem and it was solved by selecting the initially hidden
option int the mixer "external amplifier". Maybe this should be enabled by default?

Comment 6 Roger J. Allen 2005-06-16 03:31:20 UTC
Thanks!  That fixed the sound from both the snd_atiixp and pcspkr.

Applications>Sound & Video>Volume Control
check External Amplifier

That creates a new tab called Switches!

Also, the snd_atiixp_modem doesn't need to be blacklisted.

Now playing "Nobody's Fault but Mine" 

Note You need to log in before you can comment on or make changes to this bug.