Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 160388 - device ownership is reset to defaults following reboot
Summary: device ownership is reset to defaults following reboot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-14 20:35 UTC by shawn murphy
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-22 14:59:08 UTC


Attachments (Terms of Use)

Description shawn murphy 2005-06-14 20:35:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)

Description of problem:
I have a RHEL 4 kernel 2.6.9-6.37.EL.  I am installing Oracle which requires that devices be assigned oracle:dba ownership. 

Following a reboot devices assigned to oracle:dba are reset to root:disk ownership.  I have seen this in 2 scenarios: when assigning native sd devices  or bound raw devices.

this forces me to edit my oracle service script to chown on startup. Is this expected behavior?  

Thanks,
Shawn

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. chown oracle:dba /dev/sdt
2. reboot
3. ls -l /dev/sdt (results in root:disk) ownership
  

Expected Results:  Device ownership assignments should survive reboots

Additional info:

Comment 1 Suzanne Hillman 2005-06-15 17:23:28 UTC
This report looks like a support request. In order to file a support issue,
please either contact Red Hat's Technical Support line at 888-REDHAT-1 or file a
web ticket at http://www.redhat.com/apps/support/.  Bugzilla is not an official
support channel, has no response guarantees, and may not route your issue to the
correct area to assist you.  Using the official support channels above will
guarantee that your issue is handled appropriately and routed to the individual
or group which can best assist you with this issue and will also allow Red Hat
to track the issue, ensuring that any applicable bug fix is included in all
releases and is not dropped from a future update or major release.

Comment 2 Jason Baron 2005-06-21 21:33:04 UTC
I think these would be set 'permanently' via udev. Did our support resolve this
for you? thanks.

Comment 3 shawn murphy 2005-06-22 14:59:08 UTC
Yes changing the ownership in the *.permissions file under /etc/udev worked. 
Thanks.


Note You need to log in before you can comment on or make changes to this bug.